summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-02 11:02:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-02 15:12:49 +0200
commit979d8464d4539999a5132caf935cf12fb941b0f4 (patch)
tree717a9b8fc1befd6beca46aaee4bed436d95be3a9 /gnu
parent61b77ff307b875bf198dd3d71ef64d1871d0ac6e (diff)
downloadpatches-979d8464d4539999a5132caf935cf12fb941b0f4.tar
patches-979d8464d4539999a5132caf935cf12fb941b0f4.tar.gz
gnu: python-pillow: Make check phase conditional.
* gnu/packages/python-xyz.scm (python-pillow)[arguments]: Wrap custom 'check phase in check for 'tests?'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 59f712844f..c628c989d2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4706,13 +4706,15 @@ the OleFileIO module from PIL, the Python Image Library.")
(substitute* "setup.py"
(("\\['/sbin/ldconfig', '-p'\\]") "['true']"))))
(replace 'check
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (begin
- (setenv "HOME" (getcwd))
- ;; Make installed package available for running the tests.
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "selftest.py" "--installed")
- (invoke "python" "-m" "pytest" "-vv")))))))
+ (lambda* (#:key outputs inputs tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ (setenv "HOME" (getcwd))
+ ;; Make installed package available for running the tests.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "selftest.py" "--installed")
+ (invoke "python" "-m" "pytest" "-vv"))
+ #t))))))
(home-page "https://python-pillow.org")
(synopsis "Fork of the Python Imaging Library")
(description