summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-02-22 20:51:59 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-23 14:46:19 +0100
commit94b28aed1e4f151997cb2bc70df20f0eea11ee1b (patch)
tree79ccb3c6b4574fe836fe6eb457bd144cb53ea408 /gnu
parent2b7d10d2db9f5e2dc2afb0d8711ce67e0a63229b (diff)
downloadpatches-94b28aed1e4f151997cb2bc70df20f0eea11ee1b.tar
patches-94b28aed1e4f151997cb2bc70df20f0eea11ee1b.tar.gz
gnu: prosody: Update to 0.9.12.
* gnu/packages/messaging.scm (prosody): Update to 0.9.12. [inputs]: Change lua5.1-sec-0.5 to lua5.1-sec. * gnu/packages/lua.scm (lua5.1-sec-0.5): Remove variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lua.scm12
-rw-r--r--gnu/packages/messaging.scm7
2 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 5016732b7a..e3ab3561cb 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -283,18 +283,6 @@ communication. It takes an already established TCP connection and creates a
secure session between the peers.")
(license (package-license lua-5.1))))
-(define-public lua5.1-sec-0.5
- (package
- (inherit lua5.1-sec)
- (version "0.5.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/brunoos/luasec/archive/"
- "luasec-" version ".tar.gz"))
- (sha256
- (base32
- "01llf5bcrjmqqy6m65avqkajz7h79rvkka6rd131kwr10n75yp3d"))))))
-
(define-public lua-lgi
(package
(name "lua-lgi")
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9345e24263..0ffc031c85 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -495,14 +495,14 @@ end-to-end encryption support; XML console.")
(define-public prosody
(package
(name "prosody")
- (version "0.9.10")
+ (version "0.9.12")
(source (origin
(method url-fetch)
(uri (string-append "https://prosody.im/downloads/source/"
"prosody-" version ".tar.gz"))
(sha256
(base32
- "0bv6s5c0iizz015hh1lxlwlw1iwvisywajm2rcrbdfyrskzfwdj8"))))
+ "139yxqpinajl32ryrybvilh54ddb1q6s0ajjhlcs4a0rnwia6n8s"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
@@ -572,8 +572,7 @@ end-to-end encryption support; XML console.")
("lua5.1-expat" ,lua5.1-expat)
("lua5.1-socket" ,lua5.1-socket)
("lua5.1-filesystem" ,lua5.1-filesystem)
- ;; See <https://prosody.im/doc/depends#luasec>.
- ("lua5.1-sec" ,lua5.1-sec-0.5)))
+ ("lua5.1-sec" ,lua5.1-sec)))
(home-page "https://prosody.im/")
(synopsis "Jabber (XMPP) server")
(description "Prosody is a modern XMPP communication server. It aims to