summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-12-12 18:29:23 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2017-12-13 05:15:21 +0300
commit91b21ba9f712bce033b717422c3d2022ffe8a70a (patch)
tree918e163b14d0a07f849d49b461152cd84412913e /gnu
parent40761f57adaceb0e2a9f498fd6a3a25b4eb1324a (diff)
downloadpatches-91b21ba9f712bce033b717422c3d2022ffe8a70a.tar
patches-91b21ba9f712bce033b717422c3d2022ffe8a70a.tar.gz
gnu: cgit: Patch absolute file names.
* gnu/packages/version-control.scm (cgit): Patch absolute file names.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6820b28bae..cbf5ce7d87 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -539,6 +539,18 @@ collaboration using typical untrusted file hosts or services.")
(zero? (system*
"tar" "--strip-components=1" "-C" "git" "-xf"
(assoc-ref inputs "git:src")))))
+ (add-after 'unpack 'patch-absolute-file-names
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (quoted-file-name input path)
+ (string-append "\"" input path "\""))
+ (substitute* "ui-snapshot.c"
+ (("\"gzip\"")
+ (quoted-file-name (assoc-ref inputs "gzip") "/bin/gzip"))
+ (("\"bzip2\"")
+ (quoted-file-name (assoc-ref inputs "bzip2") "/bin/bzip2"))
+ (("\"xz\"")
+ (quoted-file-name (assoc-ref inputs "xz") "/bin/xz")))
+ #t))
(delete 'configure) ; no configure script
(add-after 'build 'build-man
(lambda* (#:key make-flags #:allow-other-keys)
@@ -559,7 +571,10 @@ collaboration using typical untrusted file hosts or services.")
#t)))))))
(native-inputs
;; For building manpage.
- `(("asciidoc" ,asciidoc)))
+ `(("asciidoc" ,asciidoc)
+ ("gzip" ,gzip)
+ ("bzip2" ,bzip2)
+ ("xz" ,xz)))
(inputs
`(;; Cgit directly accesses some internal Git interfaces that changed in
;; Git 2.12. Try removing this special input and using the source of the