summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 01:38:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 02:52:56 +0200
commit7f4b45a320d9661881e9cd488507bee2cf84e859 (patch)
tree9dd11666443d2749bfec144bf999a3d7ea8e73af /gnu
parentaa784dc850fd683ade4dee7f2e2ad630e604b432 (diff)
downloadpatches-7f4b45a320d9661881e9cd488507bee2cf84e859.tar
patches-7f4b45a320d9661881e9cd488507bee2cf84e859.tar.gz
gnu: soundconverter: Update to 3.0.2.
* gnu/packages/gnome.scm (soundconverter): Update to 3.0.2. [source]: Remove upstreamed patch. * gnu/packages/patches/soundconverter-remove-gconf-dependency.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm7
-rw-r--r--gnu/packages/patches/soundconverter-remove-gconf-dependency.patch29
3 files changed, 2 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 025dfe114b..118a9e24eb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1498,7 +1498,6 @@ dist_patch_DATA = \
%D%/packages/patches/slim-display.patch \
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
- %D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
%D%/packages/patches/steghide-fixes.patch \
%D%/packages/patches/suitesparse-mongoose-cmake.patch \
%D%/packages/patches/superlu-dist-awpm-grid.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e4bb056e4c..fe874100b2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9198,7 +9198,7 @@ mp3, Ogg Vorbis and FLAC")
(define-public soundconverter
(package
(name "soundconverter")
- (version "3.0.1")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
@@ -9207,10 +9207,7 @@ mp3, Ogg Vorbis and FLAC")
"soundconverter-" version ".tar.xz"))
(sha256
- (base32 "1d6x1yf8psqbd9zbybxivfqg55khcnngp2mn92l161dfdk9512c5"))
- (patches
- (search-patches
- "soundconverter-remove-gconf-dependency.patch"))))
+ (base32 "1jv8m82hi23ilrgdznlc1jhp2jm8bw1yrw0chh3qw2l0sixvkl11"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:imported-modules ((guix build python-build-system)
diff --git a/gnu/packages/patches/soundconverter-remove-gconf-dependency.patch b/gnu/packages/patches/soundconverter-remove-gconf-dependency.patch
deleted file mode 100644
index 29cdeb6e8d..0000000000
--- a/gnu/packages/patches/soundconverter-remove-gconf-dependency.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Tue, 19 Feb 2019 07:46:28 +0100
-Subject: [PATCH] gnu: soundconverter: Catch (and ignore) the right error.
-
-Without this patch and GConf:
-
- Traceback (most recent call last):
- File "/gnu/…/bin/...soundconverter-real-real-real", line 164, in <module>
- from soundconverter.batch import cli_convert_main
- File "/gnu/…/lib/soundconverter/python/soundconverter/batch.py", line 31, in <module>
- from soundconverter.gstreamer import TagReader
- File "/gnu/…/lib/soundconverter/python/soundconverter/gstreamer.py", line 70, in <module>
- gi.require_version('GConf', '2.0')
- File "/gnu/…/lib/python3.7/site-packages/gi/__init__.py", line 130, in require_version
- raise ValueError('Namespace %s not available' % namespace)
- ValueError: Namespace GConf not available
----
-diff -Naur soundconverter-3.0.1/soundconverter/gstreamer.py soundconverter-3.0.1/soundconverter/gstreamer.py
---- soundconverter-3.0.1/soundconverter/gstreamer.py 2018-11-23 20:38:46.000000000 +0100
-+++ soundconverter-3.0.1/soundconverter/gstreamer.py 2019-02-19 07:42:15.767684388 +0100
-@@ -88,7 +88,7 @@
- profile = description, extension, pipeline
- audio_profiles_list.append(profile)
- audio_profiles_dict[description] = profile
--except ImportError:
-+except ValueError:
- pass
-
- required_elements = ('decodebin', 'fakesink', 'audioconvert', 'typefind', 'audiorate')