summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-31 17:57:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:11 +0100
commit7a19c76f00e9bd6444a2e1f3d313d66232df7d92 (patch)
treefb7b22f46b72ea1f0273082ff98c9304f99892ca /gnu
parentd94d34c4a5ca0b832e2cf140c547253d693fb140 (diff)
downloadpatches-7a19c76f00e9bd6444a2e1f3d313d66232df7d92.tar
patches-7a19c76f00e9bd6444a2e1f3d313d66232df7d92.tar.gz
gnu: Add r-stm.
* gnu/packages/cran.scm (r-stm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9a343ba507..92b48741d1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19530,3 +19530,37 @@ David M. Blei and co-authors and the C++ code for fitting LDA models using
Gibbs sampling by Xuan-Hieu Phan and co-authors.")
(license license:gpl2)))
+(define-public r-stm
+ (package
+ (name "r-stm")
+ (version "1.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "stm" version))
+ (sha256
+ (base32
+ "1yyfxaxqc6yq0yq68zhdnhpwpvsyp71dlmivn7zxixfmp932s6cn"))))
+ (properties `((upstream-name . "stm")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-glmnet" ,r-glmnet)
+ ("r-lda" ,r-lda)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-quadprog" ,r-quadprog)
+ ("r-quanteda" ,r-quanteda)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-slam" ,r-slam)
+ ("r-stringr" ,r-stringr)))
+ (home-page "http://www.structuraltopicmodel.com/")
+ (synopsis "Estimation of the Structural Topic Model")
+ (description
+ "The @dfn{Structural Topic Model} (STM) allows researchers to estimate
+topic models with document-level covariates. The package also includes tools
+for model selection, visualization, and estimation of topic-covariate
+regressions.")
+ (license license:expat)))
+