summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-23 18:18:45 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-23 18:21:44 +0100
commit558a5122fad8a396190eed01f2230f86076d9238 (patch)
tree5f8edf27041f6ea37a6dc08e2f368b633cd6c469 /gnu
parentff1cbb95383b25cf1d6b533c8a046329ee53d1db (diff)
downloadpatches-558a5122fad8a396190eed01f2230f86076d9238.tar
patches-558a5122fad8a396190eed01f2230f86076d9238.tar.gz
gnu: sdl: Propagate libx11.
* gnu/packages/sdl.scm (sdl): Propagate LIBX11. (sdl-gfx, sdl-ttf): Remove LIBX11 from 'inputs'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sdl.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 37b074dcc7..fa1b5da4eb 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -55,8 +55,10 @@
"005d993xcac8236fpvd1iawkz4wqjybkpn8dbwaliqz5jfkidlyn"))))
(build-system gnu-build-system)
(arguments '(#:tests? #f)) ; no check target
- (inputs `(("libx11" ,libx11)
- ("libxrandr" ,libxrandr)
+ (propagated-inputs
+ ;; SDL headers include X11 headers.
+ `(("libx11" ,libx11)))
+ (inputs `(("libxrandr" ,libxrandr)
("mesa" ,mesa)
("alsa-lib" ,alsa-lib)
("pkg-config" ,pkg-config)
@@ -118,7 +120,6 @@ system, such as sound redirection over the network.")
"064islldm4r42lgj9fr4kbk66r7jmmakk9745hhyb1kmw71kib9h"))))
(build-system gnu-build-system)
(propagated-inputs `(("sdl" ,sdl)))
- (inputs `(("libx11" ,libx11)))
(synopsis "SDL graphics primitives library")
(description "SDL_gfx provides graphics drawing primitives, rotozoom and
other supporting functions for SDL.")
@@ -218,7 +219,6 @@ SDL.")
(build-system gnu-build-system)
(propagated-inputs `(("sdl" ,sdl)))
(inputs `(("freetype" ,font:freetype)
- ("libx11" ,libx11)
("mesa" ,mesa)
("pkg-config" ,pkg-config)))
(synopsis "SDL TrueType font library")