summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-07-15 10:19:35 +0300
committerDanny Milosavljevic <dannym@scratchpost.org>2017-07-15 10:45:14 +0200
commit4ff9e8685f2b5180cff3c2f557b60fb71dcec83f (patch)
treeea01d8a5c1be4530c963c5cc13cc59c1d9465928 /gnu
parent7734ed7af73dabb8cbc89b8d6807b78f2f91c8fa (diff)
downloadpatches-4ff9e8685f2b5180cff3c2f557b60fb71dcec83f.tar
patches-4ff9e8685f2b5180cff3c2f557b60fb71dcec83f.tar.gz
gnu: Add python-backports-csv.
* gnu/packages/python.scm (python-backports-csv, python2-backports-csv): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 83bef4b77e..6db8a02430 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6373,6 +6373,31 @@ connection to each user.")
(define-public python2-backports-abc
(package-with-python2 python-backports-abc))
+(define-public python-backports-csv
+ (package
+ (name "python-backports-csv")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "backports.csv" version))
+ (sha256
+ (base32
+ "1imzbrradkfn8s2m1qcimyn74dn1mz2p3j381jljn166rf2i6hlc"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/ryanhiebert/backports.csv")
+ (synopsis "Backport of Python 3's csv module for Python 2")
+ (description
+ "Provides a backport of Python 3's @code{csv} module for parsing
+comma separated values. The API of the @code{csv} module in Python 2
+is drastically different from the @code{csv} module in Python 3.
+This is due, for the most part, to the difference between str in
+Python 2 and Python 3.")
+ (license license:psfl)))
+
+(define-public python2-backports-csv
+ (package-with-python2 python-backports-csv))
+
(define-public python2-backports-shutil-get-terminal-size
(package
(name "python2-backports-shutil-get-terminal-size")