summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-27 22:49:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-27 23:05:06 +0200
commit49464d2b160cd496a14278f4da0dd89168023a67 (patch)
tree09ad640fecb51e5f8037e524637f348f63aa9181 /gnu
parent2c19ff18e27a5425155057eaf098d424f1c38766 (diff)
downloadpatches-49464d2b160cd496a14278f4da0dd89168023a67.tar
patches-49464d2b160cd496a14278f4da0dd89168023a67.tar.gz
gnu: emacs-google-maps: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-google-maps)[source]: Download using git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cb4c4dd627..dc9c3cd4d9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1485,13 +1485,14 @@ written in the Go programming language.")
(name "emacs-google-maps")
(version "1.0.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/jd/google-maps.el/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jd/google-maps.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "014bxapm4d8vjxbzrfjdpsavxyfx981mlcb10aq5rmigr6il8ybs"))))
+ "183igr5lp20zcqi7rc01fk76sfxdhksd74i11v16gdsifdkjimd0"))))
(build-system emacs-build-system)
(home-page "https://github.com/jd/google-maps.el")
(synopsis "Access Google Maps from Emacs")