summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-04 14:07:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:11 +0100
commit3d7115398f3cb1be7609f9ff852292db7c3ac78a (patch)
tree70b414099e485f6e17e9604497a4e99ab9b29b8e /gnu
parent247bd124dbbaa5f1f24920aade3f2a4c2db7e7d2 (diff)
downloadpatches-3d7115398f3cb1be7609f9ff852292db7c3ac78a.tar
patches-3d7115398f3cb1be7609f9ff852292db7c3ac78a.tar.gz
gnu: Add r-sem.
* gnu/packages/cran.scm (r-sem): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1902ea4f08..30eee24d60 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19690,3 +19690,30 @@ calculations for probability, econometric and numerical analysis. There are
additional functions that are comparable to APL functions which are useful for
actuarial models such as pension mathematics.")
(license license:gpl2+)))
+
+(define-public r-sem
+ (package
+ (name "r-sem")
+ (version "3.1-9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sem" version))
+ (sha256
+ (base32
+ "1f9c6g6pfx66gd2pappcsqh484ah6a0x4z47hpd46rah0817hcsa"))))
+ (properties `((upstream-name . "sem")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot)
+ ("r-mass" ,r-mass)
+ ("r-matrixcalc" ,r-matrixcalc)
+ ("r-mi" ,r-mi)))
+ (home-page "https://cran.r-project.org/package=sem")
+ (synopsis "Structural equation models")
+ (description
+ "This package provides functions for fitting general linear structural
+equation models (with observed and latent variables) using the RAM approach,
+and for fitting structural equations in observed-variable models by two-stage
+least squares.")
+ (license license:gpl2+)))