summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-04 14:07:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:12 +0100
commit27d9764d063b0f607fe7635366eedea166f7fda7 (patch)
treea10226d2f953120fab9aff3bf43b0069024ffa16 /gnu
parent3d7115398f3cb1be7609f9ff852292db7c3ac78a (diff)
downloadpatches-27d9764d063b0f607fe7635366eedea166f7fda7.tar
patches-27d9764d063b0f607fe7635366eedea166f7fda7.tar.gz
gnu: Add r-semtools.
* gnu/packages/cran.scm (r-semtools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 30eee24d60..67546a513c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19717,3 +19717,24 @@ equation models (with observed and latent variables) using the RAM approach,
and for fitting structural equations in observed-variable models by two-stage
least squares.")
(license license:gpl2+)))
+
+(define-public r-semtools
+ (package
+ (name "r-semtools")
+ (version "0.5-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "semTools" version))
+ (sha256
+ (base32
+ "1zj841pszfsikzp82cmh463qyc4xhdrqjqcnhc2r8mcflv12irv6"))))
+ (properties `((upstream-name . "semTools")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lavaan" ,r-lavaan)))
+ (home-page "https://github.com/simsem/semTools/wiki")
+ (synopsis "Useful tools for structural equation modeling")
+ (description
+ "This package provides useful tools for structural equation modeling.")
+ (license license:gpl2+)))