summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-04 13:31:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:11 +0100
commit247bd124dbbaa5f1f24920aade3f2a4c2db7e7d2 (patch)
tree5c61e8d3f94c5a5e989bf2c1120469584c2fe129 /gnu
parent8ef53c2255841a8a0f3504d031f69e8765d9a572 (diff)
downloadpatches-247bd124dbbaa5f1f24920aade3f2a4c2db7e7d2.tar
patches-247bd124dbbaa5f1f24920aade3f2a4c2db7e7d2.tar.gz
gnu: Add r-matrixcalc.
* gnu/packages/cran.scm (r-matrixcalc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 32c6663780..1902ea4f08 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19668,3 +19668,25 @@ generate the imputations, confidence-building mechanisms to validate some of
the assumptions of the imputation algorithm, and functions to analyze multiply
imputed data sets with the appropriate degree of sampling uncertainty.")
(license license:gpl2+)))
+
+(define-public r-matrixcalc
+ (package
+ (name "r-matrixcalc")
+ (version "1.0-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "matrixcalc" version))
+ (sha256
+ (base32
+ "1c4w9dhi5w98qj1wwh9bbpnfk39rhiwjbanalr8bi5nmxkpcmrhp"))))
+ (properties `((upstream-name . "matrixcalc")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/matrixcalc/")
+ (synopsis "Collection of functions for matrix calculations")
+ (description
+ "This package provides a collection of functions to support matrix
+calculations for probability, econometric and numerical analysis. There are
+additional functions that are comparable to APL functions which are useful for
+actuarial models such as pension mathematics.")
+ (license license:gpl2+)))