summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-23 16:07:29 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-23 16:07:29 +0100
commit0ece70747028ee88c58dc90b1089b4f74f243015 (patch)
tree2969bf0a8e1bef133c1de3c7c1c57336e8518ead /gnu
parentd321bf4c27d7a40954f15061c16335bf3035a194 (diff)
downloadpatches-0ece70747028ee88c58dc90b1089b4f74f243015.tar
patches-0ece70747028ee88c58dc90b1089b4f74f243015.tar.gz
gnu: make-bootstrap: Add missing inputs for Canadian cross of '%gcc-static'.
* gnu/packages/make-bootstrap.scm (%gcc-static): Add 'native-inputs' field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 7f7a808542..d621a634a3 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -418,7 +418,21 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
((#:make-flags flags)
(if (%current-target-system)
`(cons "LDFLAGS=-static" ,flags)
- `(cons "BOOT_LDFLAGS=-static" ,flags)))))))))
+ `(cons "BOOT_LDFLAGS=-static" ,flags))))))
+ (native-inputs
+ (if (%current-target-system)
+ `(;; When doing a Canadian cross, we need GMP/MPFR/MPC both
+ ;; as target inputs and as native inputs; the latter is
+ ;; needed when building build-time tools ('genconstants',
+ ;; etc.) Failing to do that leads to misdetections of
+ ;; declarations by 'gcc/configure', and eventually to
+ ;; duplicate declarations as reported in
+ ;; <http://gcc.gnu.org/bugzilla/show_bug.cgi?id=59217>.
+ ("gmp-native" ,gmp)
+ ("mpfr-native" ,mpfr)
+ ("mpc-native" ,mpc)
+ ,@(package-native-inputs gcc-4.8))
+ (package-native-inputs gcc-4.8))))))
(define %gcc-stripped
;; The subset of GCC files needed for bootstrap.