summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-04 15:07:50 +0200
committerRoel Janssen <roel@gnu.org>2018-04-04 15:07:50 +0200
commit0d5c19452f49c317505e24f415a5a8fdd1fe54f8 (patch)
tree6af6c909286ad80443c9466c7a0a27a5ce6617f5 /gnu
parentea09f99f7fcdde57589f83cfc66e813b084013f9 (diff)
downloadpatches-0d5c19452f49c317505e24f415a5a8fdd1fe54f8.tar
patches-0d5c19452f49c317505e24f415a5a8fdd1fe54f8.tar.gz
gnu: Add perl-font-ttf.
* gnu/packages/perl.scm (perl-font-ttf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9676920e17..34ea031699 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9199,6 +9199,30 @@ File::Find replacement in Perl.")
interface to File::Find::Object.")
(license (package-license perl))))
+(define-public perl-font-ttf
+ (package
+ (name "perl-font-ttf")
+ (version "1.06")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BH/BHALLISSY/Font-TTF-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14y29ja3lsa3yw0ll20lj96f3zz5zydjqi1c5nh9wxar8927ssab"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-io-string" ,perl-io-string)))
+ (home-page "http://search.cpan.org/dist/Font-TTF/")
+ (synopsis "TTF font support for Perl")
+ (description "This package provides a Perl module for TrueType/OpenType
+font hacking. It supports reading, processing and writing of the following
+tables: GDEF, GPOS, GSUB, LTSH, OS/2, PCLT, bsln, cmap, cvt, fdsc, feat,
+fpgm, glyf, hdmx, head, hhea, hmtx, kern, loca, maxp, mort, name, post, prep,
+prop, vhea, vmtx and the reading and writing of all other table types.")
+ (license artistic2.0)))
+
(define-public perl-libtime-parsedate
(package
(name "perl-libtime-parsedate")