summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-11-10 19:38:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-11 07:03:06 +0100
commit074ff555abaf587aec927bc897ccde90d7ecafac (patch)
treedd5f511b8e419a0b84e78207f4486a5b805d8fa5 /gnu
parentce1ac8eea6fa16ce483fcacca035af4e13245c41 (diff)
downloadpatches-074ff555abaf587aec927bc897ccde90d7ecafac.tar
patches-074ff555abaf587aec927bc897ccde90d7ecafac.tar.gz
gnu: libreoffice: Update to 5.3.7.2 and enable GTK3.
* gnu/packages/libreoffice.scm (libreoffice): Update to 5.3.7.2 [source]: Change URL to HTTPS. [inputs]: Add gtk+. [configure-flags]: Remove "--disable-gtk3". Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 9980837c85..f5a6ee4f7e 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -871,16 +872,16 @@ and to return information on pronunciations, meanings and synonyms.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "5.3.6.1")
+ (version "5.3.7.2")
(source
(origin
(method url-fetch)
(uri
(string-append
- "http://download.documentfoundation.org/libreoffice/src/"
+ "https://download.documentfoundation.org/libreoffice/src/"
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
(sha256 (base32
- "023a7hr7v5cf0ipga4ijhyl58ncgbjrp500qq5fwf65j8g2c3apz"))))
+ "0z7fssp0jcj09wxad1wmhy69n71a2mwl933lxp9dz5sdvzncxmy3"))))
(build-system gnu-build-system)
(native-inputs
`(;; autoreconf is run by the LibreOffice build system, since after
@@ -907,7 +908,8 @@ and to return information on pronunciations, meanings and synonyms.")
("gperf" ,gperf)
("graphite2" ,graphite2)
("gst-plugins-base" ,gst-plugins-base)
- ("gtk+" ,gtk+-2)
+ ("gtk+" ,gtk+)
+ ("gtk+-2" ,gtk+-2)
("harfbuzz" ,harfbuzz)
("hunspell" ,hunspell)
("hyphen" ,hyphen)
@@ -1054,8 +1056,7 @@ and to return information on pronunciations, meanings and synonyms.")
"--disable-coinmp"
"--disable-firebird-sdbc" ; embedded firebird
"--disable-gltf"
- "--without-doxygen"
- "--disable-gtk3")))
+ "--without-doxygen")))
(home-page "https://www.libreoffice.org/")
(synopsis "Office suite")
(description "LibreOffice is a comprehensive office suite. It contains