summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-04-04 13:27:26 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-04 14:39:39 +0200
commit03efe78c3483ea046fd050bf9b6eeadee08e7236 (patch)
treed72c00f3d7d440d8ffa102042c4e9b43aa5953e5 /gnu
parent95f3b626d7117571df9a9bd48dd5109213395215 (diff)
downloadpatches-03efe78c3483ea046fd050bf9b6eeadee08e7236.tar
patches-03efe78c3483ea046fd050bf9b6eeadee08e7236.tar.gz
gnu: Add emacs-password-store.
* gnu/packages/emacs.scm (emacs-password-store): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7c1b190d2d..fd0b8acd0e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -101,6 +101,7 @@
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gd)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages password-utils)
#:use-module (guix utils)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
@@ -7458,3 +7459,38 @@ Anzu.zim.")
"Unfold CSS-selector-like expressions to markup. It is intended to be
used with SGML-like languages: XML, HTML, XHTML, XSL, etc.")
(license license:gpl3+)))
+
+(define-public emacs-password-store
+ (package
+ (name "emacs-password-store")
+ (version "1.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://git.zx2c4.com/password-store/snapshot/"
+ "password-store-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0scqkpll2q8jhzcgcsh9kqz0gwdpvynivqjmmbzax2irjfaiklpn"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'extract-el-file
+ (lambda _
+ (copy-file "contrib/emacs/password-store.el" "password-store.el")
+ (delete-file-recursively "contrib")
+ (delete-file-recursively "man")
+ (delete-file-recursively "src")
+ (delete-file-recursively "tests"))))))
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)
+ ("password-store" ,password-store)))
+ (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
+ (synopsis "Password store (pass) support for Emacs")
+ (description
+ "This package provides functions for working with pass (\"the
+standard Unix password manager\").")
+ (license license:gpl2+)))
+