summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-10-07 23:29:07 -0500
committerEric Bavier <bavier@member.fsf.org>2019-10-13 11:08:56 -0500
commit0163b9002ab6fac5f2fc470e2d3baf6a188ccfc7 (patch)
tree14c49ac855ee33edcab7cbf70b47d9b572e07ff0 /gnu
parent55af64560543409789b4ab61d9bf4c2457e8a3ac (diff)
downloadpatches-0163b9002ab6fac5f2fc470e2d3baf6a188ccfc7.tar
patches-0163b9002ab6fac5f2fc470e2d3baf6a188ccfc7.tar.gz
gnu: Add pragha.
* gnu/packages/music.scm (pragha): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm51
1 files changed, 50 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4c74ae5ffa..66ff861dc3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
@@ -4628,3 +4628,52 @@ easier to perform. Features include:
@item Adjust tempo; Playback speed of loops can be adjusted on the fly.
@end itemize\n")
(license license:gpl2))))
+
+(define-public pragha
+ (package
+ (name "pragha")
+ (version "1.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pragha-music-player/pragha/"
+ "releases/download/v" version "/pragha-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "19kbhq99bkimx3aqrdzln0vlr4slkpx6kq66j731jvqyq76nlkp5"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("grilo" ,grilo)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("gtk+" ,gtk+)
+ ("libcddb" ,libcddb)
+ ("libcdio" ,libcdio)
+ ("libcdio-paranoia" ,libcdio-paranoia)
+ ("libgudev" ,libgudev)
+ ("libnotify" ,libnotify)
+ ("libpeas" ,libpeas)
+ ("libsoup" ,libsoup)
+ ("sqlite" ,sqlite)
+ ("taglib" ,taglib)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/pragha")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))
+ #t))))))
+ (home-page "https://pragha-music-player.github.io")
+ (synopsis "Music player")
+ (description "Pragha is a lightweight music player based on Gtk and
+sqlite. It is constructed to be fast, light, and simultaneously tries to be
+complete without obstructing your daily work.")
+ (license license:gpl3+)))