summaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-04-28 14:15:28 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-05-05 16:13:53 +0200
commitf19cf27c2b9ff92e2c0fd931ef7fde39c376adaa (patch)
tree6d4805a1c7496e3e1e7c55084b84bd7ece348805 /gnu/tests
parentf8fd1157174fd523d36dcfa756c965a54c30d5ae (diff)
downloadpatches-f19cf27c2b9ff92e2c0fd931ef7fde39c376adaa.tar
patches-f19cf27c2b9ff92e2c0fd931ef7fde39c376adaa.tar.gz
image: Add a new API.
Raw disk-images and ISO9660 images are created in a Qemu virtual machine. This is quite fragile, very slow, and almost unusable without KVM. For all these reasons, add support for host image generation. This implies the use new image generation mechanisms. - Raw disk images: images of partitions are created using tools such as mke2fs and mkdosfs depending on the partition file-system type. The partition images are then assembled into a final image using genimage. - ISO9660 images: the ISO root directory is populated within the store. GNU xorriso is then called on that directory, in the exact same way as this is done in (gnu build vm) module. Those mechanisms are built upon the new (gnu image) module. * gnu/image.scm: New file. * gnu/system/image.scm: New file. * gnu/build/image: New file. * gnu/local.mk: Add them. * gnu/system/vm.scm (system-disk-image): Rename to system-disk-image-in-vm. * gnu/ci.scm (qemu-jobs): Adapt to new API. * gnu/tests/install.scm (run-install): Ditto. * guix/scripts/system.scm (system-derivation-for-action): Ditto.
Diffstat (limited to 'gnu/tests')
-rw-r--r--gnu/tests/install.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/tests/install.scm b/gnu/tests/install.scm
index 23f60c68bf..2e5913953e 100644
--- a/gnu/tests/install.scm
+++ b/gnu/tests/install.scm
@@ -22,9 +22,11 @@
(define-module (gnu tests install)
#:use-module (gnu)
#:use-module (gnu bootloader extlinux)
+ #:use-module (gnu image)
#:use-module (gnu tests)
#:use-module (gnu tests base)
#:use-module (gnu system)
+ #:use-module (gnu system image)
#:use-module (gnu system install)
#:use-module (gnu system vm)
#:use-module ((gnu build vm) #:select (qemu-command))
@@ -229,14 +231,18 @@ packages defined in installation-os."
;; we cheat a little bit by adding TARGET to its GC
;; roots. This way, we know 'guix system init' will
;; succeed.
- (image (system-disk-image
- (operating-system-with-gc-roots
- os (list target))
- #:disk-image-size install-size
- #:file-system-type
- installation-disk-image-file-system-type
- ;; Don't provide substitutes; too big.
- #:substitutable? #f)))
+ (image
+ (system-image
+ (image
+ (inherit
+ (find-image
+ installation-disk-image-file-system-type))
+ (size install-size)
+ (operating-system
+ (operating-system-with-gc-roots
+ os (list target)))
+ ;; Don't provide substitutes; too big.
+ (substitutable? #f)))))
(define install
(with-imported-modules '((guix build utils)
(gnu build marionette))