summaryrefslogtreecommitdiff
path: root/gnu/system
diff options
context:
space:
mode:
authorCaliph Nomble <nomble@palism.com>2019-10-14 02:01:53 -0400
committerVagrant Cascadian <vagrant@debian.org>2019-10-18 13:32:09 -0700
commitfa7470189eed39ae863f8f269fd3ef29bb084f16 (patch)
treeb87c31734be69fd6b66dd303b0c91c27453dbacd /gnu/system
parentc07f3b184d6ed81a5f60850fe563092b07784e3b (diff)
downloadpatches-fa7470189eed39ae863f8f269fd3ef29bb084f16.tar
patches-fa7470189eed39ae863f8f269fd3ef29bb084f16.tar.gz
gnu: Add u-boot-rockpro64-rk3399
* gnu/packages/bootloaders.scm (u-boot-rockpro64-rk3399): New exported variable. (u-boot-2019.10): New variable. * gnu/bootloader/u-boot.scm (u-boot-rockpro64-rk3399-bootloader): New exported variable. (install-rockpro64-rk3399-u-boot): New variable. * gnu/system/install.scm (rockpro64-installation-os): New exported variable. Adjusted-by: Vagrant Cascadian <vagrant@debian.org> Signed-off-by: Caliph Nomble <nomble@palism.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/install.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 912096027f..eab3649269 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -62,6 +62,7 @@
novena-installation-os
pine64-plus-installation-os
pinebook-installation-os
+ rockpro64-installation-os
rk3399-puma-installation-os
wandboard-installation-os
os-with-u-boot))
@@ -583,6 +584,11 @@ The bootloader BOOTLOADER is installed to BOOTLOADER-TARGET."
"/dev/mmcblk0" ; SD card storage
"ttyS0"))
+(define rockpro64-installation-os
+ (embedded-installation-os u-boot-rockpro64-rk3399-bootloader
+ "/dev/mmcblk0" ; SD card/eMMC (SD priority) storage
+ "ttyS2")) ; UART2 connected on the Pi2 bus
+
(define rk3399-puma-installation-os
(embedded-installation-os u-boot-puma-rk3399-bootloader
"/dev/mmcblk0" ; SD card storage