summaryrefslogtreecommitdiff
path: root/gnu/system/examples/desktop.tmpl
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-09 23:16:11 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-09 23:53:36 +0200
commit36ffaca2469e6a98e23f59c4a7e82ed985710310 (patch)
treeedcc607f08d79f9aafce3917a21b0de303f2aa4b /gnu/system/examples/desktop.tmpl
parentc217cbd84d7aee7414945a6cf85e1d704fff6e32 (diff)
downloadpatches-36ffaca2469e6a98e23f59c4a7e82ed985710310.tar
patches-36ffaca2469e6a98e23f59c4a7e82ed985710310.tar.gz
doc: Add desktop configuration example.
* gnu/system/examples/bare-bones.tmpl: Change 'packages' and 'host-name'. Remove D-Bus, Avahi, and SLiM services, and add lsh instead. * gnu/system/examples/desktop.tmpl: New file. * Makefile.am (EXAMPLES): Add it.
Diffstat (limited to 'gnu/system/examples/desktop.tmpl')
-rw-r--r--gnu/system/examples/desktop.tmpl42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/system/examples/desktop.tmpl b/gnu/system/examples/desktop.tmpl
new file mode 100644
index 0000000000..07e3f0b1d6
--- /dev/null
+++ b/gnu/system/examples/desktop.tmpl
@@ -0,0 +1,42 @@
+;; This is an operating system configuration template
+;; for a "desktop" setup with X11.
+
+(use-modules (gnu) (gnu system nss))
+(use-service-modules desktop)
+(use-package-modules xfce ratpoison wicd avahi xorg)
+
+(operating-system
+ (host-name "antelope")
+ (timezone "Europe/Paris")
+ (locale "en_US.UTF-8")
+
+ ;; Assuming /dev/sdX is the target hard disk, and "root" is
+ ;; the label of the target root file system.
+ (bootloader (grub-configuration (device "/dev/sdX")))
+ (file-systems (cons (file-system
+ (device "root")
+ (title 'label)
+ (mount-point "/")
+ (type "ext4"))
+ %base-file-systems))
+
+ (users (list (user-account
+ (name "bob")
+ (comment "Alice's brother")
+ (group "users")
+ (supplementary-groups '("wheel"
+ "audio" "video"))
+ (home-directory "/home/bob"))))
+
+ ;; Add Xfce and Ratpoison; that allows us to choose
+ ;; sessions using either of these at the log-in screen.
+ (packages (cons* xfce ratpoison ;desktop environments
+ xterm wicd avahi ;useful tools
+ %base-packages))
+
+ ;; Use the "desktop" services, which include the X11
+ ;; log-in service, networking with Wicd, and more.
+ (services %desktop-services)
+
+ ;; Allow resolution of '.local' host names with mDNS.
+ (name-service-switch %mdns-host-lookup-nss))