summaryrefslogtreecommitdiff
path: root/gnu/system.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-02 22:24:02 -0400
committerLeo Famulari <leo@famulari.name>2016-08-10 15:41:21 -0400
commit9f58fe3d1c32e3f0ced065e286532a10cad1b5e3 (patch)
tree63b9a04ff14876970031ef5748cd37a34817d592 /gnu/system.scm
parent2d558e31af5c8207dc4149d2f5c468c6542b99b1 (diff)
downloadpatches-9f58fe3d1c32e3f0ced065e286532a10cad1b5e3.tar
patches-9f58fe3d1c32e3f0ced065e286532a10cad1b5e3.tar.gz
gnu: glibc/linux: Adjust variable name to upstream change.
* gnu/packages/base.scm (glibc/linux)[arguments]: Change 'libc_cv_localedir' to 'libc_cv_complocaledir' in #:configure-flags. * gnu/system.scm: (operating-system-environment-variables): Remove 'GUIX_LOCPATH'.
Diffstat (limited to 'gnu/system.scm')
-rw-r--r--gnu/system.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/system.scm b/gnu/system.scm
index d6bf6c413c..04dd7a845c 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -545,12 +545,7 @@ use 'plain-file' instead~%")
;; By default, applications that use D-Bus, such as Emacs, abort at startup
;; when /etc/machine-id is missing. Make sure these warnings are non-fatal.
- ("DBUS_FATAL_WARNINGS" . "0")
-
- ;; XXX: Normally we wouldn't need to do this, but our glibc@2.23 package
- ;; looks things up in 'PREFIX/lib/locale' instead of
- ;; '/run/current-system/locale' as was intended.
- ("GUIX_LOCPATH" . "/run/current-system/locale")))
+ ("DBUS_FATAL_WARNINGS" . "0")))
(define %setuid-programs
;; Default set of setuid-root programs.