summaryrefslogtreecommitdiff
path: root/gnu/services/docker.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-12-31 00:39:02 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-10 03:00:55 +0100
commit8af4c335e32fbed7556a4cd7f26f93bc66afaace (patch)
tree2265b19aca1e5cd77a9ae43d0a47209b7fffdf63 /gnu/services/docker.scm
parentf87ea24a821c1cee8f9a8f0d38d7f02fa43d8383 (diff)
downloadpatches-8af4c335e32fbed7556a4cd7f26f93bc66afaace.tar
patches-8af4c335e32fbed7556a4cd7f26f93bc66afaace.tar.gz
services: Add docker.
* gnu/services/docker.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * doc/guix.texi (Miscellaneous Services): Document the service.
Diffstat (limited to 'gnu/services/docker.scm')
-rw-r--r--gnu/services/docker.scm94
1 files changed, 94 insertions, 0 deletions
diff --git a/gnu/services/docker.scm b/gnu/services/docker.scm
new file mode 100644
index 0000000000..6d270831b3
--- /dev/null
+++ b/gnu/services/docker.scm
@@ -0,0 +1,94 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services docker)
+ #:use-module (gnu services)
+ #:use-module (gnu services configuration)
+ #:use-module (gnu services base)
+ #:use-module (gnu services dbus)
+ #:use-module (gnu services shepherd)
+ #:use-module (gnu system shadow)
+ #:use-module (gnu packages docker)
+ #:use-module (guix records)
+ #:use-module (guix gexp)
+ #:use-module (guix packages)
+
+ #:export (docker-configuration
+ docker-service-type))
+
+(define-configuration docker-configuration
+ (docker
+ (package docker)
+ "Docker daemon package.")
+ (containerd
+ (package containerd)
+ "containerd package."))
+
+(define %docker-accounts
+ (list (user-group (name "docker") (system? #t))))
+
+(define (%containerd-activation config)
+ (let ((state-dir "/var/lib/containerd"))
+ #~(begin
+ (use-modules (guix build utils))
+ (mkdir-p #$state-dir))))
+
+(define (%docker-activation config)
+ (%containerd-activation config)
+ (let ((state-dir "/var/lib/docker"))
+ #~(begin
+ (use-modules (guix build utils))
+ (mkdir-p #$state-dir))))
+
+(define (containerd-shepherd-service config)
+ (let* ((package (docker-configuration-containerd config)))
+ (shepherd-service
+ (documentation "containerd daemon.")
+ (provision '(containerd))
+ (start #~(make-forkexec-constructor
+ (list (string-append #$package "/bin/containerd"))))
+ (stop #~(make-kill-destructor)))))
+
+(define (docker-shepherd-service config)
+ (let* ((docker (docker-configuration-docker config)))
+ (shepherd-service
+ (documentation "Docker daemon.")
+ (provision '(dockerd))
+ (requirement '(containerd))
+ (start #~(make-forkexec-constructor
+ (list (string-append #$docker "/bin/dockerd")
+ "-p" "/var/run/docker.pid")
+ #:pid-file "/var/run/docker.pid"
+ #:log-file "/var/log/docker.log"))
+ (stop #~(make-kill-destructor)))))
+
+(define docker-service-type
+ (service-type (name 'docker)
+ (description "Provide capability to run Docker application
+bundles in Docker containers.")
+ (extensions
+ (list
+ (service-extension activation-service-type
+ %docker-activation)
+ (service-extension shepherd-root-service-type
+ (lambda args
+ (list (apply containerd-shepherd-service args)
+ (apply docker-shepherd-service args))))
+ (service-extension account-service-type
+ (const %docker-accounts))))
+ (default-value (docker-configuration))))