summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 16:47:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 16:47:01 +0100
commit34f849a945d25daa76d93839dcf8768c8b45b636 (patch)
tree33cde8cf068593f29366ba3702aabdb75b5fa126 /gnu/packages
parent0897ad7fac04fc9d814e83eed46e88c7bf9740bc (diff)
parentc09f598d94af81f326fe1d4cf2ab344d4e720679 (diff)
downloadpatches-34f849a945d25daa76d93839dcf8768c8b45b636.tar
patches-34f849a945d25daa76d93839dcf8768c8b45b636.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm41
-rw-r--r--gnu/packages/disk.scm6
-rw-r--r--gnu/packages/games.scm24
-rw-r--r--gnu/packages/gnome.scm1
-rw-r--r--gnu/packages/graph.scm4
-rw-r--r--gnu/packages/graphics.scm10
-rw-r--r--gnu/packages/kde.scm3
-rw-r--r--gnu/packages/lisp.scm31
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/statistics.scm12
-rw-r--r--gnu/packages/video.scm18
11 files changed, 91 insertions, 63 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b0160347c9..46521323c0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5813,14 +5813,14 @@ clustering.")
(define-public r-factominer
(package
(name "r-factominer")
- (version "1.42")
+ (version "2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "FactoMineR" version))
(sha256
(base32
- "1yl16inb2m89l1czgaf0pgy9655dpr751hyx92yw6rqpd2ryznac"))))
+ "0qiw60ypf3bf5xsqz2b9l82i4jvprjm8lzpp12lhl8d9j5s8m0j8"))))
(properties `((upstream-name . "FactoMineR")))
(build-system r-build-system)
(propagated-inputs
@@ -5828,6 +5828,8 @@ clustering.")
("r-cluster" ,r-cluster)
("r-ellipse" ,r-ellipse)
("r-flashclust" ,r-flashclust)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggrepel" ,r-ggrepel)
("r-lattice" ,r-lattice)
("r-leaps" ,r-leaps)
("r-mass" ,r-mass)
@@ -6419,14 +6421,14 @@ documents.")
(define-public r-writexl
(package
(name "r-writexl")
- (version "1.1")
+ (version "1.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "writexl" version))
(sha256
(base32
- "0w4wnpl3yhaqp63p32bk60xrbmd7xd11kxifjbzrghi7d4483a46"))))
+ "09fhdip6igcg97fjx4c7727cx2lb49l4d74l4i8rg2bag2s5lrj3"))))
(build-system r-build-system)
(inputs `(("zlib" ,zlib)))
(home-page "https://github.com/ropensci/writexl")
@@ -8068,14 +8070,14 @@ Hothorn, Westfall, 2010, CRC Press).")
(define-public r-emmeans
(package
(name "r-emmeans")
- (version "1.4.2")
+ (version "1.4.3.01")
(source
(origin
(method url-fetch)
(uri (cran-uri "emmeans" version))
(sha256
(base32
- "1sxwbh6sym2shrj7gva8q96ca2csqz3081q4d84avpxz15dfz1z1"))))
+ "16v5j31516nbqnj2zhgqvyp5yxd4zcs5zi0aspa5plr2qikvrkmg"))))
(build-system r-build-system)
(propagated-inputs
`(("r-estimability" ,r-estimability)
@@ -10044,14 +10046,14 @@ Touzet and Varre (2007).")
(define-public r-rnifti
(package
(name "r-rnifti")
- (version "1.0.0")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "RNifti" version))
(sha256
(base32
- "0l61hjnzv043ibpkgrhc0yngaqmc58lkvii8j1dzh022z5wbqrj8"))))
+ "0hfid40pgfi1ykqka8y3v0m7h0iyd6fbvycvqlad3ibmbg621f0w"))))
(properties `((upstream-name . "RNifti")))
(build-system r-build-system)
(propagated-inputs `(("r-rcpp" ,r-rcpp)))
@@ -10157,14 +10159,14 @@ handling.")
(define-public r-grimport
(package
(name "r-grimport")
- (version "0.9-2")
+ (version "0.9-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "grImport" version))
(sha256
(base32
- "0n3y6dzy8s0ifvyrgwbly6cl14lmgd54dyi74s5i984apszpsp16"))))
+ "109mrdvq06xq3zgn9ngz0c7zzgqkv5zbpvsb2i636vmlk6y4dpkd"))))
(properties `((upstream-name . "grImport")))
(build-system r-build-system)
(inputs
@@ -10181,14 +10183,14 @@ PostScript pictures in R plots.")
(define-public r-grimport2
(package
(name "r-grimport2")
- (version "0.1-5")
+ (version "0.2-0")
(source
(origin
(method url-fetch)
(uri (cran-uri "grImport2" version))
(sha256
(base32
- "0dyb3nrrvxnkk9q5b136bdivcz1jj3ajx1kscm3k0kkpqjif0pls"))))
+ "19q0dd8fpp1g4xf6sg5f8dxybwxjfw553ra6wgjd8b74fzca40m1"))))
(properties `((upstream-name . "grImport2")))
(build-system r-build-system)
(propagated-inputs
@@ -10212,18 +10214,17 @@ be imported and then exported via the @code{gridSVG} package.")
(define-public r-kohonen
(package
(name "r-kohonen")
- (version "3.0.8")
+ (version "3.0.10")
(source
(origin
(method url-fetch)
(uri (cran-uri "kohonen" version))
(sha256
(base32
- "1zbfqa1qdlry8w6xhypkiknc5gn98v1ijhlsfka8zjg8ajhqgn1q"))))
+ "1ck7j13x701g67bx81x7plszz804jfhl1yg42krcj9x88vm5cscr"))))
(build-system r-build-system)
(propagated-inputs
- `(("r-mass" ,r-mass)
- ("r-rcpp" ,r-rcpp)))
+ `(("r-rcpp" ,r-rcpp)))
(home-page "https://cran.r-project.org/web/packages/kohonen")
(synopsis "Supervised and unsupervised self-organising maps")
(description
@@ -15432,13 +15433,13 @@ function and interfaces to external frameworks.")
(define-public r-covr
(package
(name "r-covr")
- (version "3.3.2")
+ (version "3.4.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "covr" version))
(sha256
- (base32 "160w0m2d06kdd8dar57lpph39rxx55xwncbpl3b21l7j9drh1s5f"))))
+ (base32 "0p44kr6yz5sqza5zvq6divqglzkpv0if9pjpjmzhmdaaddjrqzg5"))))
(properties `((upstream-name . "covr")))
(build-system r-build-system)
(propagated-inputs
@@ -15636,13 +15637,13 @@ effect size.")
(define-public r-rgdal
(package
(name "r-rgdal")
- (version "1.4-7")
+ (version "1.4-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "rgdal" version))
(sha256
- (base32 "05rvqy8lr2c3phaylmc4g5761208b0xrmgwn9c4a60x7p251dzjs"))))
+ (base32 "1jd691amf3ghznq5im15gvhl6v6k25klpl75m4ngrqf9xlxaa3as"))))
(properties `((upstream-name . "rgdal")))
(build-system r-build-system)
(inputs
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 88a917dda7..1a6a7c40f6 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
@@ -364,10 +364,10 @@ and can dramatically shorten the lifespan of the drive if left unchecked.")
("glib" ,glib)
("gtkmm" ,gtkmm)
("libxml2" ,libxml2)
- ("yelp-tools" ,yelp-tools)
- ("itstool" ,itstool)))
+ ("yelp-tools" ,yelp-tools)))
(native-inputs
`(("intltool" ,intltool)
+ ("itstool" ,itstool)
("lvm2" ,lvm2) ; for tests
("pkg-config" ,pkg-config)))
(home-page "https://gparted.org/")
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 613b3acfeb..b25133db78 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2019 nee <nee-git@hidamari.blue>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -5139,7 +5139,7 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(define-public tome4
(package
(name "tome4")
- (version "1.6.1")
+ (version "1.6.4")
(synopsis "Single-player, RPG roguelike game set in the world of Eyal")
(source
(origin
@@ -5148,7 +5148,7 @@ Crowther & Woods, its original authors, in 1995. It has been known as
version ".tar.bz2"))
(sha256
(base32
- "0c5a2bdyfccwkqnb6yqvzggyi2nk032v01kfc00zlgpdfzljcb9i"))
+ "1hrh79aqmvwwd7idlr3lzpdpc9dgm1k5p7w2462chcjvd8vhfhb7"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -6888,6 +6888,22 @@ a fortress beyond the forbidden swamp.")
(("PATH_SUFFIXES \"src\" \"gtest\"")
"PATH_SUFFIXES \"src\""))
#t))
+ (add-after 'unpack 'adjust-backward-cpp-includes
+ (lambda _
+ ;; XXX: The bundled backward-cpp exports a CMake "interface"
+ ;; that includes external libraries such as libdl from glibc.
+ ;; By default, CMake interface includes are treated as "system
+ ;; headers", and GCC behaves poorly when glibc is passed as a
+ ;; system header (causing #include_next failures).
+
+ ;; Here we prevent targets that consume the Backward::Backward
+ ;; interface from treating it as "system includes".
+ (substitute* "CMakeLists.txt"
+ (("target_link_libraries\\((.+) Backward::Backward\\)" all target)
+ (string-append "set_property(TARGET " target " PROPERTY "
+ "NO_SYSTEM_FROM_IMPORTED true)\n"
+ all)))
+ #t))
(add-after 'unpack 'add-libiberty
;; Build fails upon linking executables without this.
(lambda _
@@ -6939,7 +6955,7 @@ a fortress beyond the forbidden swamp.")
"Multiplayer action game where you control small and nimble humanoids")
(description "OpenClonk is a multiplayer action/tactics/skill game. It is
often referred to as a mixture of The Settlers and Worms. In a simple 2D
-antfarm-style landscape, the player controls his crew of Clonks, small but
+antfarm-style landscape, the player controls a crew of Clonks, small but
robust humanoid beings. The game encourages free play but the normal goal is
to either exploit valuable resources from the earth by building a mine or
fight each other on an arena-like map.")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 11ed035919..4e5e8cdbfd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2431,6 +2431,7 @@ selection and URL hints.")))
(patches (search-patches
"vte-CVE-2012-2738-pt1.patch"
"vte-CVE-2012-2738-pt2.patch"))))
+ (build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-python")))
(native-inputs
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 9979b176d7..326477730b 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -107,14 +107,14 @@ more.")
(define-public r-igraph
(package
(name "r-igraph")
- (version "1.2.4.1")
+ (version "1.2.4.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "igraph" version))
(sha256
(base32
- "1074y8mvprrqlkb4vwa2qc9l03r8d7p5vaaqacj4ljjs7dvcq6l9"))))
+ "0scrbqb26pam8akblb4g9rkz888s0xffw3gcly78s4ijj67barxd"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8795107dcb..3ef420cf05 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -71,6 +71,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages tbb)
#:use-module (gnu packages video)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -87,14 +88,14 @@
(define-public blender
(package
(name "blender")
- (version "2.80")
+ (version "2.81")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
- "blender-" version ".tar.gz"))
+ "blender-" version ".tar.xz"))
(sha256
(base32
- "1h550jisdbis50hxwk5kxrvrk1a6sh2fsri3yyj66vhzbi87x7fd"))))
+ "1prp0f2152f1sz23jlc86vndfvmplb7qhllikkirq7hgpykrshna"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
@@ -145,6 +146,8 @@
`(("boost" ,boost)
("jemalloc" ,jemalloc)
("libx11" ,libx11)
+ ("libxi" ,libxi)
+ ("libxrender" ,libxrender)
("openimageio" ,openimageio)
("openexr" ,openexr)
("opensubdiv" ,opensubdiv)
@@ -162,6 +165,7 @@
("openal" ,openal)
("python" ,python)
("python-numpy" ,python-numpy)
+ ("tbb" ,tbb)
("zlib" ,zlib)))
(home-page "https://blender.org/")
(synopsis "3D graphics creation suite")
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 636b5d60ba..742e003433 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -517,8 +517,9 @@ cards.")
(arguments
`(#:tests? #f)) ; both tests fail, require display
(inputs
+ `(("qtbase" ,qtbase)))
+ (native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
- ("qtbase" ,qtbase)
("qttools" ,qttools)))
(home-page "https://techbase.kde.org/Projects/Snorenotify")
(synopsis "Qt notification framework")
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index fdde7f744c..9a83a1598a 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
@@ -1469,16 +1469,17 @@ JavaScript (ECMAScript 3). It has basic support for ECMAScript 5.")
(define-public sbcl-parse-number
(package
(name "sbcl-parse-number")
- (version "1.5")
+ (version "1.7")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/sharplispers/parse-number/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharplispers/parse-number/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1k6s4v65ksc1j5i0dprvzfvj213v6nah7i0rgd0726ngfjisj9ir"))))
+ "0sk06ib1bhqv9y39vwnnw44vmbc4b0kvqm37xxmkxd4dwchq82d7"))))
(build-system asdf-build-system/sbcl)
(home-page "http://www.cliki.net/PARSE-NUMBER")
(synopsis "Parse numbers")
@@ -4140,11 +4141,13 @@ encoding table that uses only URI-compatible characters.")
(version "1.1.7")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/edicl/chunga/archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/edicl/chunga.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0ra17kyc9l7qbaw003ly111r1cbn4zixbfq1ydr9cxw10v30q1n7"))))
+ (base32 "0jzn3nyb3f22gm983rfk99smqs3mhb9ivjmasvhq9qla5cl9pyhd"))))
(build-system asdf-build-system/sbcl)
(inputs
`(("sbcl-trivial-gray-streams" ,sbcl-trivial-gray-streams)))
@@ -4923,6 +4926,7 @@ reset to 0 and you're able to read it again.")
(uri (git-reference
(url "https://github.com/fukamachi/lack.git")
(commit commit)))
+ (file-name (git-file-name "lack-request" version))
(sha256
(base32 "1avh4ygcj9xcx4m17nj0wnxxaisk26w4ljs2bibzxaln24x7pi85"))))
(build-system asdf-build-system/sbcl)
@@ -5039,6 +5043,7 @@ performance and simplicity in mind.")
(uri (git-reference
(url "https://github.com/fukamachi/lack.git")
(commit commit)))
+ (file-name (git-file-name "lack-component" version))
(sha256
(base32 "1avh4ygcj9xcx4m17nj0wnxxaisk26w4ljs2bibzxaln24x7pi85"))))
(build-system asdf-build-system/sbcl)
@@ -5074,6 +5079,7 @@ performance and simplicity in mind.")
(uri (git-reference
(url "https://github.com/fukamachi/lack.git")
(commit commit)))
+ (file-name (git-file-name "lack-util" version))
(sha256
(base32 "1avh4ygcj9xcx4m17nj0wnxxaisk26w4ljs2bibzxaln24x7pi85"))))
(build-system asdf-build-system/sbcl)
@@ -5111,6 +5117,7 @@ performance and simplicity in mind.")
(uri (git-reference
(url "https://github.com/fukamachi/lack.git")
(commit commit)))
+ (file-name (git-file-name "lack-middleware-backtrace" version))
(sha256
(base32 "1avh4ygcj9xcx4m17nj0wnxxaisk26w4ljs2bibzxaln24x7pi85"))))
(build-system asdf-build-system/sbcl)
@@ -5193,6 +5200,7 @@ mime-type of a file.")
(uri (git-reference
(url "https://github.com/fukamachi/lack.git")
(commit commit)))
+ (file-name (git-file-name "lack-middleware-static" version))
(sha256
(base32 "1avh4ygcj9xcx4m17nj0wnxxaisk26w4ljs2bibzxaln24x7pi85"))))
(build-system asdf-build-system/sbcl)
@@ -5232,6 +5240,7 @@ performance and simplicity in mind.")
(uri (git-reference
(url "https://github.com/fukamachi/lack.git")
(commit commit)))
+ (file-name (git-file-name "lack" version))
(sha256
(base32 "1avh4ygcj9xcx4m17nj0wnxxaisk26w4ljs2bibzxaln24x7pi85"))))
(build-system asdf-build-system/sbcl)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8f4a2334d9..9095984811 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4088,8 +4088,7 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(assoc-ref inputs "jquery-ui")
"-d" dir))
#t))
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key outputs inputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "python" "tests.py" "-v"
@@ -4147,6 +4146,7 @@ toolkits.")
(assoc-ref inputs "jquery-ui")
"-d" dir))
#t))
+ (delete 'fix-and-disable-failing-tests)
(delete 'check))))) ; These tests weren't run the the past.
;; Make sure to use special packages for Python 2 instead
;; of those automatically rewritten by package-with-python2.
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1c315c23ef..a2ab913c6c 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -567,14 +567,14 @@ also flexible enough to handle most nonstandard requirements.")
(define-public r-matrix
(package
(name "r-matrix")
- (version "1.2-17")
+ (version "1.2-18")
(source
(origin
(method url-fetch)
(uri (cran-uri "Matrix" version))
(sha256
(base32
- "1k1zf92ycqr7fz44w7bp1p354ww7jg0wm23ybb8dzmbg37qfchyv"))))
+ "06b1rc1vq65b271f2wpzhqkvhng8hwwnvjflzxkng50i52603zzp"))))
(properties `((upstream-name . "Matrix")))
(build-system r-build-system)
(propagated-inputs
@@ -2661,13 +2661,13 @@ certain criterion, e.g., it contains a certain regular file.")
(define-public r-rmarkdown
(package
(name "r-rmarkdown")
- (version "1.17")
+ (version "1.18")
(source
(origin
(method url-fetch)
(uri (cran-uri "rmarkdown" version))
(sha256
- (base32 "18dj6nr1m79pv1pv9w2n0rhiidwqjb2w8w1rnpcwijwbz4i8d3k2"))))
+ (base32 "0fykzbb5kjsqc8v6gjcdma7rmq0gailp30qij6plgna4d8nhjw3w"))))
(properties `((upstream-name . "rmarkdown")))
(build-system r-build-system)
(propagated-inputs
@@ -3332,14 +3332,14 @@ Stochastic Neighbor Embedding using a Barnes-Hut implementation.")
(define-public r-e1071
(package
(name "r-e1071")
- (version "1.7-2")
+ (version "1.7-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "e1071" version))
(sha256
(base32
- "0lipj692rjjw8rrhqh2k9i5dh8y2sjrw9q53rwm32irhx2f2j73j"))))
+ "0pf2pjb590z0jikgv1037xcp7dq06mg3dzmyffjw6gk7dd9blbdv"))))
(build-system r-build-system)
(propagated-inputs
`(("r-class" ,r-class)))
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2ed4ed2dc1..c93531b744 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1266,7 +1266,8 @@ streaming protocols.")
(build-system gnu-build-system)
;; FIXME: Add additional inputs once available.
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("yasm" ,yasm)))
(inputs
`(("alsa-lib" ,alsa-lib)
("cdparanoia" ,cdparanoia)
@@ -1297,7 +1298,6 @@ streaming protocols.")
("python" ,python-wrapper)
("sdl" ,sdl)
("speex" ,speex)
- ("yasm" ,yasm)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ; no test target
@@ -1943,7 +1943,11 @@ for use with HTML5 video.")
(patches (search-patches "avidemux-install-to-lib.patch"))))
(build-system cmake-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("qttools" ,qttools)
+ ("yasm" ,yasm)))
;; FIXME: Once packaged, add libraries not found during the build.
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -1958,14 +1962,9 @@ for use with HTML5 video.")
("libvorbis" ,libvorbis)
("libvpx" ,libvpx)
("libxv" ,libxv)
- ("perl" ,perl)
("pulseaudio" ,pulseaudio)
- ("python" ,python-wrapper)
("qtbase" ,qtbase)
- ("qttools" ,qttools)
- ("sdl" ,sdl)
("sqlite" ,sqlite)
- ("yasm" ,yasm)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ; no check target
@@ -2002,7 +2001,6 @@ for use with HTML5 video.")
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib"))
(top (getcwd))
- (sdl (assoc-ref inputs "sdl"))
(build_component
(lambda* (component srcdir #:optional (args '()))
(let ((builddir (string-append "build_" component)))
@@ -2015,8 +2013,6 @@ for use with HTML5 video.")
(string-append "-DCMAKE_SHARED_LINKER_FLAGS="
"\"-Wl,-rpath=" lib "\"")
(string-append "-DAVIDEMUX_SOURCE_DIR=" top)
- (string-append "-DSDL_INCLUDE_DIR="
- sdl "/include/SDL")
(string-append "../" srcdir)
"-DENABLE_QT5=True"
args)