summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-17 10:05:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-17 10:10:14 +0100
commit57e4592f6387942a214bbae4d53f3df0f3e36504 (patch)
treeb79433b03958f4298ef05e50fa2034c7d143c8fa /gnu/packages
parente3545ffcf95bffbbd967efd852715f4f0a9be290 (diff)
downloadpatches-57e4592f6387942a214bbae4d53f3df0f3e36504.tar
patches-57e4592f6387942a214bbae4d53f3df0f3e36504.tar.gz
gnu: Add python2-ws4py-for-kaldi-gstreamer-server.
* gnu/packages/python-web.scm (python2-ws4py-for-kaldi-gstreamer-server): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b1a17898ff..32d769c3ed 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3068,3 +3068,29 @@ such as IoT applications or multi-user database-driven business applications.")
"This package provides a WebSocket client and server library for
Python.")
(license license:bsd-3)))
+
+;; kaldi-gstreamer-server does not yet work with python-ws4py > 0.3.2
+(define-public python2-ws4py-for-kaldi-gstreamer-server
+ (package (inherit python-ws4py)
+ (name "python2-ws4py")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ws4py" version))
+ (sha256
+ (base32
+ "12ys3dv98awhrxd570vla3hqgzq3avjhq4yafhghhq3a942y1928"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; We don't have a package for cherrypy.
+ (add-after 'unpack 'remove-cherrypy-support
+ (lambda _
+ (delete-file "ws4py/server/cherrypyserver.py")
+ #t)))))
+ (propagated-inputs
+ `(("python-gevent" ,python2-gevent)
+ ("python-tornado" ,python2-tornado)))))