summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-01-25 01:51:29 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-25 16:20:23 +0100
commit513e1950fbc1e8cc53cb9d2626aaf7c88f4a2fe4 (patch)
tree18d93d14c13f4856bbcda88ec542b12e59e85a48 /gnu/packages
parent28fb9101d940fee615f46fbf6c61299a64ae28c6 (diff)
downloadpatches-513e1950fbc1e8cc53cb9d2626aaf7c88f4a2fe4.tar
patches-513e1950fbc1e8cc53cb9d2626aaf7c88f4a2fe4.tar.gz
gnu: Add Corkscrew 2.0.
* gnu/packages/ssh.scm (corkscrew): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ssh.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 5d21eeeb01..7589408e47 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -238,3 +238,46 @@ programs written in GNU Guile interpreter. It is a wrapper to the underlying
libssh library.")
(home-page "https://github.com/artyom-poptsov/libguile-ssh")
(license license:gpl3+)))
+
+(define-public corkscrew
+ (package
+ (name "corkscrew")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.agroman.net/corkscrew/corkscrew-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; Replace configure phase as the ./configure script does not link
+ ;; CONFIG_SHELL and SHELL passed as parameters
+ '(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs inputs system target
+ #:allow-other-keys #:rest args)
+ (let* ((configure (assoc-ref %standard-phases 'configure))
+ (prefix (assoc-ref outputs "out"))
+ (bash (which "bash"))
+ ;; Set --build and --host flags as the provided config.guess
+ ;; is not able to detect them
+ (flags `(,(string-append "--prefix=" prefix)
+ ,(string-append "--build=" system)
+ ,(string-append "--host="
+ (or target system)))))
+ (setenv "CONFIG_SHELL" bash)
+ (zero? (apply system* bash
+ (string-append "." "/configure")
+ flags))))
+ %standard-phases)))
+ (home-page "http://www.agroman.net/corkscrew")
+ (synopsis "A tool for tunneling SSH through HTTP proxies")
+ (description
+ "Corkscrew allows creating TCP tunnels through HTTP proxies. WARNING:
+At the moment only plain text authentication is supported, should you require
+to use it with your HTTP proxy. Digest based authentication may be supported
+in future and NTLM based authentication is most likey never be supported.")
+ (license license:gpl2+)))