summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-11 11:25:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-03-17 23:15:57 -0400
commit4caf37b0a7d3a3969795cd1364dda7229ea8ab04 (patch)
tree59addc149275afa6d157f3ce4d2105ac2a28eb61 /gnu/packages
parent8c72f13fd45fc04ee64c9b2865a293ad8d47d1f1 (diff)
downloadpatches-4caf37b0a7d3a3969795cd1364dda7229ea8ab04.tar
patches-4caf37b0a7d3a3969795cd1364dda7229ea8ab04.tar.gz
gnu: Add python-et-xmlfile.
* gnu/packages/python.scm (python-et-xmlfile): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa2701bc1c..687e9cbd7e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -54,7 +54,7 @@
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
@@ -832,6 +832,36 @@ messages in color.")
(define-public python2-coloredlogs
(package-with-python2 python-coloredlogs))
+(define-public python-et-xmlfile
+ (package
+ (name "python-et-xmlfile")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "et_xmlfile" version))
+ (sha256
+ (base32
+ "0nrkhcb6jdrlb6pwkvd4rycw34y3s931hjf409ij9xkjsli9fkb1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-lxml" ,python-lxml))) ;used for the tests
+ (home-page "https://bitbucket.org/openpyxl/et_xmlfile")
+ (synopsis "Low memory implementation of @code{lxml.xmlfile}")
+ (description "This Python library is based upon the @code{xmlfile} module
+from @code{lxml}. It aims to provide a low memory, compatible implementation
+of @code{xmlfile}.")
+ (license license:expat)))
+
+(define-public python2-et-xmlfile
+ (package-with-python2 python-et-xmlfile))
+
(define-public python-eventlet
(package
(name "python-eventlet")