summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-20 12:10:22 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-20 15:21:24 +0100
commite2333ea39181d74d3ffb9a5d2c83172278694423 (patch)
treec2383c3b72ab03b7e027da3f117e0d122b50f713 /gnu/packages
parent347eb21e1df4d064131f5fd076d5f4f3b44b541d (diff)
downloadpatches-e2333ea39181d74d3ffb9a5d2c83172278694423.tar
patches-e2333ea39181d74d3ffb9a5d2c83172278694423.tar.gz
gnu: Add ruby-text.
* gnu/packages/ruby.scm (ruby-text): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 326cae060b..0a31efbab4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -990,6 +990,24 @@ localization.")
(home-page "https://github.com/ruby-gettext/locale")
(license (list license:lgpl3+ license:ruby))))
+(define-public ruby-text
+ (package
+ (name "ruby-text")
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "text" version))
+ (sha256
+ (base32
+ "1x6kkmsr49y3rnrin91rv8mpc3dhrf3ql08kbccw8yffq61brfrg"))))
+ (build-system ruby-build-system)
+ (synopsis "Collection of text algorithms for Ruby")
+ (description
+ "This package provides a collection of text algorithms: Levenshtein,
+Soundex, Metaphone, Double Metaphone, Porter Stemming.")
+ (home-page "http://github.com/threedaymonk/text")
+ (license license:expat)))
+
(define-public ruby-minitest
(package
(name "ruby-minitest")