summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 19:11:54 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:20 -0600
commit4eca62be493fc0f8447dc3b235412e517edf2b48 (patch)
treec74acfd5f51cfe0ae87f08184bc85bab8b19c903 /gnu/packages
parent19206f5eb87c283d8e125f4e910b17ae25b618f7 (diff)
downloadpatches-4eca62be493fc0f8447dc3b235412e517edf2b48.tar
patches-4eca62be493fc0f8447dc3b235412e517edf2b48.tar.gz
gnu: Add ghc-chasingbottoms.
* gnu/packages/haskell.scm (ghc-chasingbottoms): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 29ff5c2678..dc361eb172 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2997,6 +2997,44 @@ is an inductive definition of graphs in the style of algebraic data types that
encourages inductive, recursive definitions of graph algorithms.")
(license bsd-3)))
+(define-public ghc-chasingbottoms
+ (package
+ (name "ghc-chasingbottoms")
+ (version "1.3.0.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/ChasingBottoms/"
+ "ChasingBottoms-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fb86jd6cdz4rx3fj3r9n8d60kx824ywwy7dw4qnrdran46ja3pl"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; The Hackage page and the cabal file linked there for this package
+ ;; both list 0.7 as the upper version limit, but the source tarball
+ ;; specifies 0.6. Assume the Hackage page is correct.
+ '(substitute* "ChasingBottoms.cabal"
+ (("syb >= 0.1.0.2 && < 0.6") "syb >= 0.1.0.2 && < 0.7")))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-random" ,ghc-random)
+ ("ghc-syb" ,ghc-syb)))
+ (home-page "http://hackage.haskell.org/package/ChasingBottoms")
+ (synopsis "Testing of partial and infinite values in Haskell")
+ (description
+ ;; FIXME: There should be a @comma{} in the uref text, but it is not
+ ;; rendered properly.
+ "This is a library for testing code involving bottoms or infinite values.
+For the underlying theory and a larger example involving use of QuickCheck,
+see the article
+@uref{http://www.cse.chalmers.se/~nad/publications/danielsson-jansson-mpc2004.html,
+\"Chasing Bottoms A Case Study in Program Verification in the Presence of
+Partial and Infinite Values\"}.")
+ (license expat)))
+
(define-public ghc-unordered-containers
(package
(name "ghc-unordered-containers")