summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-20 12:12:25 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-20 15:21:24 +0100
commit21f7b7bd802fd997e71f41183a6b1125b29f8887 (patch)
treec593995fa3899746aa5bd44f1bfed1525acc55ef /gnu/packages
parent25d6d49b3e6fe097be06a2f93d842e5558ef6a1f (diff)
downloadpatches-21f7b7bd802fd997e71f41183a6b1125b29f8887.tar
patches-21f7b7bd802fd997e71f41183a6b1125b29f8887.tar.gz
gnu: Add ruby-blankslate.
* gnu/packages/ruby.scm (ruby-blankslate): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9d7c46496f..5b893c5d29 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1121,6 +1121,34 @@ objects.")
(home-page "http://github.com/floehopper/metaclass")
(license license:expat)))
+(define-public ruby-blankslate
+ (package
+ (name "ruby-blankslate")
+ (version "3.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "blankslate" version))
+ (sha256
+ (base32
+ "0fwkb4d1j9gc7vdwn2nxvwgy2g5wlag4c4bp7bl85jvq0kgp6cyx"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (zero? (system* "rspec" "spec/")))))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis "Abstract base class with no predefined methods")
+ (description
+ "BlankSlate provides an abstract base class with no predefined
+methods (except for @code{__send__} and @code{__id__}). BlankSlate is useful
+as a base class when writing classes that depend upon
+@code{method_missing} (e.g. dynamic proxies).")
+ (home-page "http://github.com/masover/blankslate")
+ (license license:expat)))
+
(define-public ruby-minitest
(package
(name "ruby-minitest")