summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-03-31 16:09:38 -0400
committerArun Isaac <arunisaac@systemreboot.net>2018-04-20 13:30:39 +0530
commitaea388cf364f5a9f05ad219500b2c83c2b47f62c (patch)
treefe9799307b8598f08c599b49d34801ae0bb2c131 /gnu/packages
parent872bda5de52a8f0514230ebc4e9680aab74f509a (diff)
downloadpatches-aea388cf364f5a9f05ad219500b2c83c2b47f62c.tar
patches-aea388cf364f5a9f05ad219500b2c83c2b47f62c.tar.gz
gnu: emacs-realgud: Fix autogen.sh after EMACSLOADPATH is set.
* gnu/packages/emacs.scm (emacs-realgud)[arguments]: Move the fix-autogen-script phase to after the set-emacs-load-path phase. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1638b9a91b..62685ef91e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3316,7 +3316,7 @@ after buffer changes.")
`(#:tests? #t
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-autogen-script
+ (add-after 'set-emacs-load-path 'fix-autogen-script
(lambda _
(substitute* "autogen.sh"
(("./configure") "sh configure"))))