summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-30 19:47:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-30 19:47:38 +0200
commitcf0d6d836730f7bdc714ecfa4287f72e029b9970 (patch)
treee5ce784d21087c3762caaf4902f17b2beca3e27d /gnu/packages
parentd54303215e93bb3c89a94daaa56324c703d717a1 (diff)
downloadpatches-cf0d6d836730f7bdc714ecfa4287f72e029b9970.tar
patches-cf0d6d836730f7bdc714ecfa4287f72e029b9970.tar.gz
gnu: meson: Update to 0.46.0.
* gnu/packages/build-tools.scm (meson): Update to 0.46.0. * gnu/packages/patches/meson-for-build-rpath.patch: Adapt.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/build-tools.scm4
-rw-r--r--gnu/packages/patches/meson-for-build-rpath.patch7
2 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 4b078e78ed..65d1bc3808 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -98,7 +98,7 @@ generate such a compilation database.")
(define-public meson
(package
(name "meson")
- (version "0.45.1")
+ (version "0.46.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -106,7 +106,7 @@ generate such a compilation database.")
version ".tar.gz"))
(sha256
(base32
- "1yqa4337nb8w92bvr91rsxmn0xkf7pmdybq9ljvnqmdvn7dv02sd"))))
+ "1w6bm43gy2swk3hmbarm0iv8m8yd8xm5jczsvfn8z2im3aq93pxp"))))
(build-system python-build-system)
(arguments
`(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
diff --git a/gnu/packages/patches/meson-for-build-rpath.patch b/gnu/packages/patches/meson-for-build-rpath.patch
index 4e20c9aed3..2151d53565 100644
--- a/gnu/packages/patches/meson-for-build-rpath.patch
+++ b/gnu/packages/patches/meson-for-build-rpath.patch
@@ -6,14 +6,13 @@ Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
-@@ -345,15 +345,6 @@
+@@ -391,14 +391,6 @@
print("Symlink creation does not work on this platform. "
"Skipping all symlinking.")
printed_symlink_error = True
-- if is_elf_platform() and os.path.isfile(outname):
+- if os.path.isfile(outname):
- try:
-- e = depfixer.Elf(outname, False)
-- e.fix_rpath(install_rpath)
+- depfixer.fix_rpath(outname, install_rpath, False)
- except SystemExit as e:
- if isinstance(e.code, int) and e.code == 0:
- pass