summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-04-03 15:15:40 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-04-03 16:08:11 +1000
commit1ef09c0c75c61fd70a84667a845a652995b38a94 (patch)
tree5547c4bad4b4993c06c98ca62222c6090e357aa7 /gnu/packages
parent78c0d323e9fae4a5b5a2b3c54eeab5a5677b7804 (diff)
downloadpatches-1ef09c0c75c61fd70a84667a845a652995b38a94.tar
patches-1ef09c0c75c61fd70a84667a845a652995b38a94.tar.gz
gnu: Add python-pbr.
* gnu/packages/python.scm (python-pbr, python2-pbr): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f91980819c..d79cb135e6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1867,6 +1867,27 @@ and sensible default behaviors into your setuptools run.")
(define-public python2-pbr-0.11
(package-with-python2 python-pbr-0.11))
+(define-public python-pbr
+ (package (inherit python-pbr-0.11)
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pbr" version))
+ (sha256
+ (base32
+ "0jcny36cf3s8ar5r4a575npz080hndnrfs4np1fqhv0ym4k7c4p2"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-fixtures" ,python-fixtures)
+ ("python-pip" ,python-pip)))
+ (properties `((python2-variant . ,(delay python2-pbr))))))
+
+(define-public python2-pbr
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-pbr)))))
+
(define-public python-fixtures
(package
(name "python-fixtures")