summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 21:06:33 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:20 -0500
commite0e21831d33b97a40cdac6fb44e873539bcbc316 (patch)
tree06044b0111249e962d28b39422923ac2ad86e467 /gnu/packages
parentacdd03be2d5c2682abec331faea1631edd9be599 (diff)
downloadpatches-e0e21831d33b97a40cdac6fb44e873539bcbc316.tar
patches-e0e21831d33b97a40cdac6fb44e873539bcbc316.tar.gz
gnu: ghc-chell-quickcheck: Update to 0.2.5.2.
* gnu/packages/haskell-xyz.scm (ghc-chell-quickcheck): Update to 0.2.5.2. [arguments]: Change the 'update-constraints' phase to allow even newer versions of 'QuickCheck'. (ghc-chell-quickcheck-bootstrap): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 416138cb62..360fbec509 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1611,7 +1611,7 @@ testing strategies.")
(define-public ghc-chell-quickcheck
(package
(name "ghc-chell-quickcheck")
- (version "0.2.5.1")
+ (version "0.2.5.2")
(source
(origin
(method url-fetch)
@@ -1620,7 +1620,7 @@ testing strategies.")
"chell-quickcheck-" version ".tar.gz"))
(sha256
(base32
- "1iicsys9igx7m7n4l2b8djardmjy2ah5ibzp7kzs758h460fq53a"))))
+ "0n8c57n88r2bx0bh8nabsz07m42rh23ahs3hgyzf8gr76l08zq03"))))
(build-system haskell-build-system)
(arguments
`(#:phases
@@ -1628,8 +1628,8 @@ testing strategies.")
(add-before 'configure 'update-constraints
(lambda _
(substitute* "chell-quickcheck.cabal"
- (("QuickCheck >= 2\\.3 && < 2\\.11")
- "QuickCheck >= 2.3 && < 2.12")))))))
+ (("QuickCheck >= 2\\.3 && < 2\\.13")
+ "QuickCheck >= 2.3 && < 2.14")))))))
(inputs
`(("ghc-chell" ,ghc-chell)
("ghc-chell-quickcheck-bootstrap" ,ghc-chell-quickcheck-bootstrap)
@@ -1643,7 +1643,7 @@ testing strategies.")
(define ghc-chell-quickcheck-bootstrap
(package
(name "ghc-chell-quickcheck-bootstrap")
- (version "0.2.5.1")
+ (version "0.2.5.2")
(source
(origin
(method url-fetch)
@@ -1652,7 +1652,7 @@ testing strategies.")
"chell-quickcheck-" version ".tar.gz"))
(sha256
(base32
- "1iicsys9igx7m7n4l2b8djardmjy2ah5ibzp7kzs758h460fq53a"))))
+ "0n8c57n88r2bx0bh8nabsz07m42rh23ahs3hgyzf8gr76l08zq03"))))
(build-system haskell-build-system)
(inputs
`(("ghc-chell" ,ghc-chell)
@@ -1665,8 +1665,8 @@ testing strategies.")
(add-before 'configure 'update-constraints
(lambda _
(substitute* "chell-quickcheck.cabal"
- (("QuickCheck >= 2\\.3 && < 2\\.11")
- "QuickCheck >= 2.3 && < 2.12")))))))
+ (("QuickCheck >= 2\\.3 && < 2\\.13")
+ "QuickCheck >= 2.3 && < 2.14")))))))
(home-page "https://john-millikin.com/software/chell/")
(synopsis "QuickCheck support for the Chell testing library")
(description "More complex tests for @code{chell}.")