summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 16:41:01 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 16:45:34 +0100
commit46429444d6dcec58690cdfeb9080cd9a4c7c7181 (patch)
tree4df8b268d5489a5a40d7b8d6d3069e57ece859b7 /gnu/packages
parent88ca4029a676a99325085a7ecede63d8b011de8f (diff)
downloadpatches-46429444d6dcec58690cdfeb9080cd9a4c7c7181.tar
patches-46429444d6dcec58690cdfeb9080cd9a4c7c7181.tar.gz
gnu: psmisc: Fix cross-compilation.
* gnu/packages/linux.scm (psmisc)[arguments]: Pass ac_cv_func_malloc_0_nonnull=yes and ac_cv_func_realloc_0_nonnull=yes options that are required when cross-compiling.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a062e2ba55..55a5ceb93c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1078,6 +1078,13 @@ at login. Local and dynamic reconfiguration are its key features.")
(sha256
(base32 "16i7qzjmm6g0lzha8yzpfrlcxnvkgh95hkq9gdjd4zmzb8d0wxa1"))))
(build-system gnu-build-system)
+ (arguments
+ `(,@(if (%current-target-system)
+ '(#:configure-flags
+ (list
+ "ac_cv_func_malloc_0_nonnull=yes"
+ "ac_cv_func_realloc_0_nonnull=yes"))
+ '())))
(inputs `(("ncurses" ,ncurses)))
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")