summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-03 18:48:16 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-03 18:48:16 +0100
commit7452806931216a5ec8712dd39327540a3307a6ce (patch)
tree5c1c5846e3faf150256641138eedf4194dbd8ab6 /gnu/packages
parentbf0baaf7db6c3ab7d54f274a8728612e323b1b08 (diff)
downloadpatches-7452806931216a5ec8712dd39327540a3307a6ce.tar
patches-7452806931216a5ec8712dd39327540a3307a6ce.tar.gz
gnu: libxml2: Wrap search path specification in a list.
Reported by Mark H Weaver. * gnu/packages/xml.scm (libxml2)[native-search-paths]: Wrap into a list.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 62f8c3c376..b4b91408af 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
@@ -72,12 +72,12 @@ things the parser might find in the XML document (like start tags).")
;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
;; sub-directory of any given package.
- (native-search-paths (search-path-specification
- (variable "XML_CATALOG_FILES")
- (separator " ")
- (files '("xml"))
- (file-pattern "^catalog\\.xml$")
- (file-type 'regular)))
+ (native-search-paths (list (search-path-specification
+ (variable "XML_CATALOG_FILES")
+ (separator " ")
+ (files '("xml"))
+ (file-pattern "^catalog\\.xml$")
+ (file-type 'regular))))
(search-paths native-search-paths)
(arguments