summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-01-27 14:43:47 +0100
committerAlex Kost <alezost@gmail.com>2017-01-28 12:41:35 +0300
commit2c5e31faac1f15962bdf6d76af41ec70c39d1a5c (patch)
tree691f6f056571f1f870fddafcfbe0f534942e3cbd /gnu/packages
parentba117841cdb1df618f04c7f52536a768d4bf9c2e (diff)
downloadpatches-2c5e31faac1f15962bdf6d76af41ec70c39d1a5c.tar
patches-2c5e31faac1f15962bdf6d76af41ec70c39d1a5c.tar.gz
gnu: Add emacs-alert.
* gnu/packages/emacs.scm (emacs-alert): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 266e45129a..d39d0ec351 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3725,3 +3725,29 @@ described at @uref{http://www.growlforwindows.com/gfw/help/gntp.aspx}.
It is incomplete as it only lets you send but not receive
notifications.")
(license license:bsd-3)))
+
+(define-public emacs-alert
+ (package
+ (name "emacs-alert")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/jwiegley/alert/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1693kck3k2iz5zhpmxwqyafxm68hr6gzs60lkxd3j1wlp2c9fwyr"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-gntp" ,emacs-gntp)
+ ("emacs-log4e" ,emacs-log4e)))
+ (home-page "https://github.com/jwiegley/alert")
+ (synopsis "Growl-style notification system for Emacs")
+ (description
+ "Alert is a Growl-workalike for Emacs which uses a common notification
+interface and multiple, selectable \"styles\", whose use is fully
+customizable by the user.")
+ (license license:gpl2+)))