summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 20:37:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:33 +0100
commitb1c5c8de92389bfa966f7b98fe9726c76e37df61 (patch)
treedd2c15269e8e8eae45f5ed2de89367eb92b13624 /gnu/packages
parent037181ed23a499c0f49c1e0e5473f44182e170de (diff)
downloadpatches-b1c5c8de92389bfa966f7b98fe9726c76e37df61.tar
patches-b1c5c8de92389bfa966f7b98fe9726c76e37df61.tar.gz
gnu: ghc-uuid-types: Fix tests with latest QuickCheck.
* gnu/packages/haskell.scm (ghc-uuid-types)[arguments]: Relax version constraint for QuickCheck.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1fd856eb2c..20d0f36056 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7857,6 +7857,8 @@ IPv4, IPv6 and MAC addresses.")
(base32
"1zdka5jnm1h6k36w3nr647yf3b5lqb336g3fkprhd6san9x52xlj"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=QuickCheck")))
(inputs `(("ghc-hashable" ,ghc-hashable)
("ghc-random" ,ghc-random)
("ghc-text" ,ghc-text)))