summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-10 16:05:49 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-11 01:14:37 +0100
commit99732a8f2286782f6e89280c0b398764aac5b31e (patch)
tree93a39c5534370f1987950b633e4cc95d40972eff /gnu/packages
parentcb669c095156eef44c1ae8aecda9931a777794ad (diff)
downloadpatches-99732a8f2286782f6e89280c0b398764aac5b31e.tar
patches-99732a8f2286782f6e89280c0b398764aac5b31e.tar.gz
gnu: orc: Update to 0.4.31.
* gnu/packages/patches/orc-typedef-enum.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gstreamer.scm (orc): Update to 0.4.31. [source](patches): Remove.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gstreamer.scm5
-rw-r--r--gnu/packages/patches/orc-typedef-enum.patch17
2 files changed, 2 insertions, 20 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 51b9d8f11c..bed9e36ce6 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -69,15 +69,14 @@
(define-public orc
(package
(name "orc")
- (version "0.4.30")
+ (version "0.4.31")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
"orc/orc-" version ".tar.xz"))
- (patches (search-patches "orc-typedef-enum.patch"))
(sha256
(base32
- "0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
+ "0xb0c7q3xv1ldmz5ipybazb01gy3cijj8622dcx7rbm9lq85zax0"))))
(build-system meson-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/orc-typedef-enum.patch b/gnu/packages/patches/orc-typedef-enum.patch
deleted file mode 100644
index 207bf32ba9..0000000000
--- a/gnu/packages/patches/orc-typedef-enum.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
-
-Taken from upstream:
-https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
-
-diff --git a/orc/orctarget.h b/orc/orctarget.h
---- a/orc/orctarget.h
-+++ b/orc/orctarget.h
-@@ -19,7 +19,7 @@ enum {
- ORC_TARGET_FAST_DENORMAL = (1<<31)
- };
-
--enum {
-+typedef enum {
- ORC_TARGET_POWERPC_64BIT = (1<<0),
- ORC_TARGET_POWERPC_LE = (1<<1),
- ORC_TARGET_POWERPC_ALTIVEC = (1<<2),