summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-03 19:13:03 -0500
committerLeo Famulari <leo@famulari.name>2018-01-10 00:07:40 -0800
commit606e2468610798b4b141c2812ff1516b83fcd2ef (patch)
tree9969b6ee95691d0ed9ec26f26b0df77062899f2f /gnu/packages
parent03674a7ca2876271c2514670d1bf1f81e6f0edee (diff)
downloadpatches-606e2468610798b4b141c2812ff1516b83fcd2ef.tar
patches-606e2468610798b4b141c2812ff1516b83fcd2ef.tar.gz
gnu: nfs-utils: Adapt to changes in glibc 2.26.
* gnu/packages/patches/nfs-utils-missing-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/nfs.scm (nfs-utils)[source]: Use it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/nfs.scm3
-rw-r--r--gnu/packages/patches/nfs-utils-missing-headers.patch19
2 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/nfs.scm b/gnu/packages/nfs.scm
index 28751c4004..f6bb5b3b71 100644
--- a/gnu/packages/nfs.scm
+++ b/gnu/packages/nfs.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
-;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +47,7 @@
(uri (string-append
"mirror://kernel.org/linux/utils/nfs-utils/" version
"/nfs-utils-" version ".tar.xz"))
+ (patches (search-patches "nfs-utils-missing-headers.patch"))
(sha256
(base32
"1vqrqzhg9nh2wj1icp7k8v9dibgnn521b45np79nnkmqf16bbbhg"))))
diff --git a/gnu/packages/patches/nfs-utils-missing-headers.patch b/gnu/packages/patches/nfs-utils-missing-headers.patch
new file mode 100644
index 0000000000..7f0542836e
--- /dev/null
+++ b/gnu/packages/patches/nfs-utils-missing-headers.patch
@@ -0,0 +1,19 @@
+Fix compilation failure with glibc 2.26 caused by missing type
+declarations:
+
+------
+rpc.c: In function ‘nsm_recv_getport’:
+rpc.c:469:13: error: ‘UINT16_MAX’ undeclared (first use in this function)
+ if (port > UINT16_MAX) {
+------
+
+--- a/support/nsm/rpc.c.orig 2016-08-03 20:25:15.000000000 +0200
++++ b/support/nsm/rpc.c 2017-08-26 07:41:11.884000000 +0200
+@@ -40,6 +40,7 @@
+
+ #include <time.h>
+ #include <stdbool.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <fcntl.h>