summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-01-27 14:43:45 +0100
committerAlex Kost <alezost@gmail.com>2017-01-28 12:41:35 +0300
commit521f5d96f7f3bf56e43892950b5302a0b560a2d2 (patch)
tree40e2eb5e11b8a1c93a6aa45d5559e02f1be7cc65 /gnu/packages
parent1e523180ae52ab5646fd0cb8e589d5acc3e9e713 (diff)
downloadpatches-521f5d96f7f3bf56e43892950b5302a0b560a2d2.tar
patches-521f5d96f7f3bf56e43892950b5302a0b560a2d2.tar.gz
gnu: Add emacs-log4e.
* gnu/packages/emacs.scm (emacs-log4e): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4737a81ce7..03de1c0684 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3671,3 +3671,33 @@ procedures for emacs-lisp-mode.")
provides functions to convert hash tables from and to alists and plists.")
(license license:gpl3+)))
+(define-public emacs-log4e
+ (package
+ (name "emacs-log4e")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/aki2o/log4e/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nbdpbw353snda3v19l9hsm6gimppwnpxj18amm350bm81lyim2g"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-tests
+ ;; Guile builder complains about null characters in some
+ ;; strings of test files. Remove "test" directory (it is not
+ ;; needed anyway).
+ (lambda _
+ (delete-file-recursively "test"))))))
+ (home-page "https://github.com/aki2o/log4e")
+ (synopsis "Logging framework for elisp")
+ (description
+ "This package provides a logging framework for elisp. It allows
+you to deal with multiple log levels.")
+ (license license:gpl3+)))