summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 12:51:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 13:17:52 +0100
commit251e08301a514fa035feb17fbb0173f9a0914015 (patch)
tree29bacc5a973e3a24516644a5eb7e3b5172b1f2fe /gnu/packages
parent648dbd2702da24a777757413c53c45a9364a8463 (diff)
downloadpatches-251e08301a514fa035feb17fbb0173f9a0914015.tar
patches-251e08301a514fa035feb17fbb0173f9a0914015.tar.gz
gnu: Add r-icobra.
* gnu/packages/bioconductor.scm (r-icobra): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0e26033d44..adc0e846d2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1898,3 +1898,37 @@ any continuous-valued or categorical variable that is thought to be
informative on the statistical properties of each hypothesis test, while it is
independent of the p-value under the null hypothesis.")
(license license:artistic2.0)))
+
+(define-public r-icobra
+ (package
+ (name "r-icobra")
+ (version "1.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "iCOBRA" version))
+ (sha256
+ (base32
+ "0i1swrm31g0zffi5pm48bfvdfqpd32d0zdchkbyipz96al46jnld"))))
+ (properties `((upstream-name . "iCOBRA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-dt" ,r-dt)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-limma" ,r-limma)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rocr" ,r-rocr)
+ ("r-scales" ,r-scales)
+ ("r-shiny" ,r-shiny)
+ ("r-shinybs" ,r-shinybs)
+ ("r-shinydashboard" ,r-shinydashboard)
+ ("r-upsetr" ,r-upsetr)))
+ (home-page "https://bioconductor.org/packages/iCOBRA")
+ (synopsis "Comparison and visualization of ranking and assignment methods")
+ (description
+ "This package provides functions for calculation and visualization of
+performance metrics for evaluation of ranking and binary
+classification (assignment) methods. It also contains a Shiny application for
+interactive exploration of results.")
+ (license license:gpl2+)))