summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-08-23 13:05:21 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-08-23 13:21:23 +0530
commitf797a0e987c29f3f146a520a355b1a661f7eb79f (patch)
tree6733764f19f59a5d26a2871073450af79a7f54a0 /gnu/packages
parente173a95ffa84b2ee7f213cf06f2f5af72f5096ed (diff)
downloadpatches-f797a0e987c29f3f146a520a355b1a661f7eb79f.tar
patches-f797a0e987c29f3f146a520a355b1a661f7eb79f.tar.gz
gnu: ghc-graphviz: Update to 2999.20.0.2.
* gnu/packages/haskell.scm (ghc-graphviz): Update to 2999.20.0.2. [native-inputs]: Add ghc-hspec, graphviz and hspec-discover.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 633ad8552d..1d1ef2b86c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages haskell-web)
@@ -7100,14 +7101,14 @@ for generating graph-like data structures.")
(define-public ghc-graphviz
(package
(name "ghc-graphviz")
- (version "2999.18.1.2")
+ (version "2999.20.0.2")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"graphviz/graphviz-" version ".tar.gz"))
(sha256
(base32
- "1z453is01v0rnxlv6xx4iyaqv5vrp3bpz829mpv1a341sck2135h"))))
+ "0kj7ap0gnliviq2p8lscw1m06capnsa90vpvcys24nqy5nw2wrp7"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags (list "--allow-newer=QuickCheck")))
@@ -7121,6 +7122,10 @@ for generating graph-like data structures.")
("ghc-temporary" ,ghc-temporary)
("ghc-text" ,ghc-text)
("ghc-wl-pprint-text" ,ghc-wl-pprint-text)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("graphviz" ,graphviz)
+ ("hspec-discover" ,hspec-discover)))
(home-page "https://hackage.haskell.org/package/graphviz")
(synopsis "Bindings to Graphviz for graph visualisation")
(description