summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-04 12:06:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-04 12:06:29 +0100
commit39ee82ffeb5b50f14536edf439d1160a18489620 (patch)
treefa1e08781d48eba16f191ed17e5852fd8f67d183 /gnu/packages
parent42f0b0c21efb42cf4879958337109771eaf28922 (diff)
downloadpatches-39ee82ffeb5b50f14536edf439d1160a18489620.tar
patches-39ee82ffeb5b50f14536edf439d1160a18489620.tar.gz
gnu: python-astor: Remove duplicate.
* gnu/packages/python-xyz.scm (python-astor): Remove duplicate.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 5 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cb9557faba..a145c54738 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7406,27 +7406,6 @@ output, progress bar display, and pipes.")
(define-public python2-clint
(package-with-python2 python-clint))
-(define-public python-astor
- (package
- (name "python-astor")
- (version "0.5")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "astor" version))
- (sha256
- (base32
- "1fdafq5hkis1fxqlmhw0sn44zp2ar46nxhbc22cvwg7hsd8z5gsa"))))
- (build-system python-build-system)
- (home-page "https://github.com/berkerpeksag/astor")
- (synopsis "Read and write Python ASTs")
- (description
- "Astor is designed to allow easy manipulation of Python source via the
-Abstract Syntax Tree.")
- (license license:bsd-3)))
-
-(define-public python2-astor
- (package-with-python2 python-astor))
-
(define-public python-rply
(package
(name "python-rply")
@@ -14680,11 +14659,14 @@ of Python libraries for building Python applications.")
;; FIXME: There are two errors and two test failures.
(arguments `(#:tests? #f))
(home-page "https://github.com/berkerpeksag/astor")
- (synopsis "Read/rewrite/write Python ASTs")
+ (synopsis "Read and write Python ASTs")
(description "Astor is designed to allow easy manipulation of Python
-source via the AST.")
+source via the Abstract Syntax Tree.")
(license license:bsd-3)))
+(define-public python2-astor
+ (package-with-python2 python-astor))
+
(define-public python-grpcio
(package
(name "python-grpcio")