summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-20 21:26:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-20 21:26:58 +0100
commit1e600ed0f7eb66497236f270c8d115a343c44243 (patch)
tree6838c589fc405148ea99710e3715d4ae8aa0564c /gnu/packages
parent046fecdcb9493044cb4875f829afdb816895df2a (diff)
downloadpatches-1e600ed0f7eb66497236f270c8d115a343c44243.tar
patches-1e600ed0f7eb66497236f270c8d115a343c44243.tar.gz
gnu: Add gamin.
* gnu/packages/gnome.scm (gamin): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6ee5187da6..dab2571fba 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8930,6 +8930,43 @@ repository and commit your work.")
(home-page "https://wiki.gnome.org/Apps/Gitg")
(license license:gpl2+)))
+(define-public gamin
+ (package
+ (name "gamin")
+ (version "0.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "02n1zr9y8q9lyczhcz0nxar1vmf8p2mmbw8kq0v43wg21jr4i6d5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-deprecated-macro
+ (lambda _
+ (substitute* '("server/gam_node.c"
+ "server/gam_subscription.h"
+ "server/gam_node.h"
+ "server/gam_subscription.c")
+ (("G_CONST_RETURN") "const"))
+ #t)))))
+ (inputs
+ `(("glib" ,glib)))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://people.gnome.org/~veillard/gamin/")
+ (synopsis "File alteration monitor")
+ (description
+ "Gamin is a file and directory monitoring system defined to be a subset
+of the FAM (File Alteration Monitor) system. This is a service provided by a
+library which allows to detect when a file or a directory has been modified.")
+ (license license:gpl2+)))
+
(define-public gnome-mahjongg
(package
(name "gnome-mahjongg")