summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-11 21:52:58 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-11 21:54:19 +0200
commited8111ea7530b1c591af016dc8d247e52cd776eb (patch)
treed7c95213a7fb09f3d91e83ae09b9ffa72b159db9 /gnu/packages
parentd5ff67f411a6a91f2cfa589d185fbc025046f1db (diff)
downloadpatches-ed8111ea7530b1c591af016dc8d247e52cd776eb.tar
patches-ed8111ea7530b1c591af016dc8d247e52cd776eb.tar.gz
gnu: linux-pam: Disable NIS when cross-compiling.
* gnu/packages/linux.scm (linux-pam)[arguments]: Pass "--disable-nis" when cross-compiling.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5c96056576..c5fed1a7c2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -426,11 +426,18 @@ It has been modified to remove all non-free binary blobs.")
;; ("cracklib" ,cracklib)
))
(arguments
- '(;; Most users, such as `shadow', expect the headers to be under
+ `(;; Most users, such as `shadow', expect the headers to be under
;; `security'.
#:configure-flags (list (string-append "--includedir="
(assoc-ref %outputs "out")
- "/include/security"))
+ "/include/security")
+
+ ;; XXX: <rpc/rpc.h> is missing from glibc when
+ ;; cross-compiling, so we have to disable NIS
+ ;; support altogether.
+ ,@(if (%current-target-system)
+ '("--disable-nis")
+ '()))
;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
;; isn't available.