summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 11:56:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:37 +0200
commitae3779d5cdd4b31a119d319d29a86c422383d765 (patch)
treece600bd406c6f510738b050c57af348a74b89b68 /gnu/packages
parent1562763c0a3cf79a38f4087d5902f02fc09d98fc (diff)
downloadpatches-ae3779d5cdd4b31a119d319d29a86c422383d765.tar
patches-ae3779d5cdd4b31a119d319d29a86c422383d765.tar.gz
gnu: Add texlive-latex-eepic.
* gnu/packages/tex.scm (texlive-latex-eepic): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 27266079e6..9841359223 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2123,6 +2123,42 @@ routine, which may be used to place the output at fixed positions. The
@code{grid} option may be used to find the correct places.")
(license license:lppl1.3+)))
+(define-public texlive-latex-eepic
+ (package
+ (name "texlive-latex-eepic")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/eepic"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "1c68gvh021pvybg07apsd2xhq2ljbg80kq94wh71drdga3c2zqjw"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/eepic")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/eepic")
+ (synopsis "Extensions to epic and the LaTeX drawing tools")
+ (description
+ "Extensions to @code{epic} and the LaTeX picture drawing environment,
+include the drawing of lines at any slope, the drawing of circles in any
+radii, and the drawing of dotted and dashed lines much faster with much less
+TeX memory, and providing several new commands for drawing ellipses, arcs,
+splines, and filled circles and ellipses. The package uses @code{tpic}
+@code{\\special} commands.")
+ (license license:public-domain)))
+
(define-public texlive-latex-multirow
(package
(name "texlive-latex-multirow")