summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 11:57:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:37 +0200
commit44436def9b169db90a188a20708a0a3a171f2a06 (patch)
tree83682fdc8e33719dfc338a3cc89118e4bff98634 /gnu/packages
parent406af0d66346565b62f94229dcbe8864acc5771c (diff)
downloadpatches-44436def9b169db90a188a20708a0a3a171f2a06.tar
patches-44436def9b169db90a188a20708a0a3a171f2a06.tar.gz
gnu: Add texlive-metapost.
* gnu/packages/tex.scm (texlive-metapost): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index afbfe6bb07..19422a3045 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2356,6 +2356,39 @@ CM-Super family of fonts. The package also offers its own LaTeX support for
OT2 encoded fonts, CM bright shaped fonts and Concrete shaped fonts.")
(license license:lppl)))
+(define-public texlive-metapost
+ (package
+ (name "texlive-metapost")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/metapost"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "03nvjddffiz796wll6axzmgfvynyciy2mqamv20qx252w71vwkwd"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/metapost")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/metapost")
+ (synopsis "Create scalable illustrations")
+ (description
+ "MetaPost uses a language based on that of Metafont to produce precise
+technical illustrations. Its output is scalable PostScript or SVG, rather
+than the bitmaps Metafont creates.")
+ (license license:lppl)))
+
(define-public texlive-latex-wasysym
(package
(name "texlive-latex-wasysym")