summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:15:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:31 +0200
commit18ce343773a77b0847e72147b947b25d8b98c8f4 (patch)
treeec9bf44f5c53d0cb3ff71bf7a60dcb5dce2bc0b4 /gnu/packages
parent20282111e5bd52c68d57d714d90c81463b2c34d0 (diff)
downloadpatches-18ce343773a77b0847e72147b947b25d8b98c8f4.tar
patches-18ce343773a77b0847e72147b947b25d8b98c8f4.tar.gz
gnu: Add texlive-latex-fancyvrb.
* gnu/packages/tex.scm (texlive-latex-fancyvrb): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2895f68478..cb56243478 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1854,6 +1854,31 @@ and footers, and for controlling their use (for example, at times when LaTeX
would automatically change the heading style in use).")
(license license:lppl)))
+(define-public texlive-latex-fancyvrb
+ (package
+ (name "texlive-latex-fancyvrb")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "fancyvrb"))
+ (sha256
+ (base32
+ "03l7140y031rr14h02i4z9zqsfvrbn7wzwxbjsrjcgrk6sdr71wv"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:build-targets '("fancyvrb.ins") ; fvrb-ex.ins cannot be built
+ #:tex-directory "latex/fancyvrb"))
+ (home-page "http://www.ctan.org/pkg/fancyvrb")
+ (synopsis "Sophisticated verbatim text")
+ (description
+ "This package provides tools for flexible handling of verbatim text
+including: verbatim commands in footnotes; a variety of verbatim environments
+with many parameters; ability to define new customized verbatim environments;
+save and restore verbatim text and environments; write and read files in
+verbatim mode; build \"example\" environments (showing both result and
+verbatim source).")
+ (license license:lppl1.0+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")