summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-31 18:58:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-31 19:01:22 +0200
commit14bb1c4842eafdba9e646573101cb2335490ee01 (patch)
tree0c9848de9c29b77f4a61bff43cd7078bc9e6c78b /gnu/packages
parent3d88855dfdcc4c8ce11f494fdf9f0ac1d8eef530 (diff)
downloadpatches-14bb1c4842eafdba9e646573101cb2335490ee01.tar
patches-14bb1c4842eafdba9e646573101cb2335490ee01.tar.gz
gnu: Add r-cicero-monocle3.
* gnu/packages/bioconductor.scm (r-cicero-monocle3): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1adf47b08f..74af02a47d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -38,7 +38,8 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages statistics)
- #:use-module (gnu packages web))
+ #:use-module (gnu packages web)
+ #:use-module (srfi srfi-1))
;;; Annotations
@@ -5128,3 +5129,25 @@ data, to only emphasize the data that actually matters.")
accessibility data. It also extends the monocle package for use in chromatin
accessibility data.")
(license license:expat)))
+
+;; This is the latest commit on the "monocle3" branch.
+(define-public r-cicero-monocle3
+ (let ((commit "fa2fb6515857a8cfc88bc9af044f34de1bcd2b7b")
+ (revision "1"))
+ (package (inherit r-cicero)
+ (name "r-cicero-monocle3")
+ (version (git-version "1.3.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cole-trapnell-lab/cicero-release.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "077yza93wdhi08n40md20jwk55k9lw1f3y0063qkk90cpz60wi0c"))))
+ (propagated-inputs
+ `(("r-monocle3" ,r-monocle3)
+ ,@(alist-delete "r-monocle"
+ (package-propagated-inputs r-cicero)))))))