summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-21 16:19:00 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-22 15:23:23 +0200
commit12c270ddd471a18a69ecfa016644c98734b3e601 (patch)
tree26ecd202e057ff35c9ef92f83cd944c74c580664 /gnu/packages
parent66e3eff1e31c4483aeb7a96ada8ea378fdc49e51 (diff)
downloadpatches-12c270ddd471a18a69ecfa016644c98734b3e601.tar
patches-12c270ddd471a18a69ecfa016644c98734b3e601.tar.gz
gnu: Add python-click.
* gnu/packages/python.scm (python-click, python2-click): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5e4217a7a1..a3f5e1ccea 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1637,6 +1637,33 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python2-certifi
(package-with-python2 python-certifi))
+(define-public python-click
+ (package
+ (name "python-click")
+ (version "4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/c/click/click-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0294x9g28w6zgswl0rsygkwi0wf6n480gf7fiiw5f9az3xhh77pl"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://click.pocoo.org")
+ (synopsis "Command line library for Python")
+ (description
+ "Click is a Python package for creating command line interfaces in a
+composable way with as little code as necessary. Its name stands for
+\"Command Line Interface Creation Kit\". It's highly configurable but comes
+with sensible defaults out of the box.")
+ (license bsd-3)))
+
+(define-public python2-click
+ (package-with-python2 python-click))
+
(define-public python-requests
(package
(name "python-requests")