summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:16:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:32 +0200
commit02fd07b305a86095423f236ff118721e0ab9eb24 (patch)
tree94f9bf84f9f099f31132263e3b5e2c1750b9a46a /gnu/packages
parentb2bc1daf98251250b21b35e9cda902372535fe6b (diff)
downloadpatches-02fd07b305a86095423f236ff118721e0ab9eb24.tar
patches-02fd07b305a86095423f236ff118721e0ab9eb24.tar.gz
gnu: Add texlive-latex-jknapltx.
* gnu/packages/tex.scm (texlive-latex-jknapltx): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5e417bf986..34dac6e5b7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1948,6 +1948,44 @@ is needed. Keywords, comments and strings can be typeset using different
styles. Support for @code{hyperref} is provided.")
(license license:lppl1.3+)))
+(define-public texlive-latex-jknapltx
+ (package
+ (name "texlive-latex-jknapltx")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/jknapltx"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "0m034x72f2g07icr50gacyxfb9g1lz2rmqh4kqr1qjb421x2kds9"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/jknapltx")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/jknappen")
+ (synopsis "Miscellaneous packages by Joerg Knappen")
+ (description
+ "This package provides miscellaneous macros by Joerg Knappen, including:
+represent counters in greek; Maxwell's non-commutative division;
+@code{latin1jk}, @code{latin2jk} and @code{latin3jk}, which are
+@code{inputenc} definition files that allow verbatim input in the respective
+ISO Latin codes; blackboard bold fonts in maths; use of RSFS fonts in maths;
+extra alignments for @code{\\parboxes}; swap Roman and Sans fonts;
+transliterate semitic languages; patches to make (La)TeX formulae embeddable
+in SGML; use maths minus in text as appropriate; simple Young tableaux.")
+ (license license:gpl2)))
+
(define texlive-texmf
(package
(name "texlive-texmf")